Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8038 closed defect (fixed)

OperationalError: database is locked

Reported by: AivoK Owned by: stoecker
Priority: normal Milestone:
Component: Trac Version:
Keywords: Cc:

Description

How to Reproduce

While doing a GET operation on /wiki/Et:Help/Concepts/Object, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'page': u'Et:Help/Concepts/Object'}

User agent: #USER_AGENT#

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 266, in dispatch
    req.session.save()
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.3-py2.7.egg/trac/web/session.py", line 105, in save
    @self.env.with_transaction()
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.3-py2.7.egg/trac/db/api.py", line 78, in transaction_wrapper
    ldb.commit()
OperationalError: database is locked

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by skyper

Component: CoreTrac
Owner: changed from team to stoecker

comment:2 Changed 6 years ago by stoecker

Resolution: fixed
Status: newclosed

Happens from time to time and I investigate each case if it can be fixed. Also I will do update to 1.0 soon, which probably reduces this issue further.

comment:3 Changed 6 years ago by stoecker

Ticket #8120 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by stoecker

Ticket #8230 has been marked as a duplicate of this ticket.

comment:5 Changed 6 years ago by stoecker

Ticket #8235 has been marked as a duplicate of this ticket.

comment:6 in reply to:  2 Changed 6 years ago by Don-vip

Replying to stoecker:

update to 1.0 soon, which probably reduces this issue further.

It seems it did not help :'(

comment:7 Changed 6 years ago by stoecker

Well issue is easy: JOSM wiki gets used more and more. Results are some pretty heavy pages which block database when loaded. Search engines really catch all these pages. To fix the issue we may need to switch to another DB engine. A little help is to forbid certain HTML pages which take LOOOOONG to load (> 100 seconds).

comment:8 Changed 6 years ago by stoecker

Ticket #8260 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.