Modify

Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#8149 closed defect (fixed)

Changeset tags handling coming from a .osm file

Reported by: _sly_ Owned by: team
Priority: normal Milestone: 16.02
Component: Core Version:
Keywords: tags changeset osm file auto Cc: Polyglot

Description

Hi,

Patch from #6742 is a rather nice option to help auto setting changesets tags for the future data integration users are going to do.

It "kind of work" but has strange behaviour in several cases
(test file included)

  • If you open that file and try a direct upload, tags in the changeset are ignored
  • If you start modifying things, tags are attached to the changeset
  • If you upload the changes, and start modifying other things, subsequent changeset will get those tags while you'd expect tags, related to the first upload to be forgotten
  • If you mess around with removing the JOSM data layers, modify things tags will hopefully be forgotten at some point
  • If you save your data layer in an osm file, changeset tags are not saved in it while it would be nice to have

Attachments (1)

test-sly.osm (594 bytes) - added by _sly_ 8 years ago.

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by _sly_

Attachment: test-sly.osm added

comment:1 Changed 8 years ago by Don-vip

Cc: Don-vip added

comment:2 Changed 8 years ago by Don-vip

Summary: Changeset tags handling comming from a .osm fileChangeset tags handling coming from a .osm file

comment:3 in reply to:  description Changed 8 years ago by Don-vip

Replying to _sly_:

  • If you open that file and try a direct upload, tags in the changeset are ignored
  • If you start modifying things, tags are attached to the changeset

Found the cause of that strange behaviour:
http://josm.openstreetmap.de/browser/josm/trunk/src/org/openstreetmap/josm/actions/UploadAction.java#L214

As written in comments, we need a proper solution :)

comment:4 Changed 8 years ago by Don-vip

Ticket #8590 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by Don-vip

Cc: Polyglot added; Don-vip removed

comment:6 Changed 8 years ago by Don-vip

From #8590 comments: Tickets #4003,#4181,#4215,#6379,#6381,#6442,#6471,#7004 should be fixed as well when looking at this ticket

comment:7 Changed 8 years ago by skyper

There are even some more concerning upload dialog:

#4535, #6103, #7090

comment:8 Changed 8 years ago by brycenesbitt

And #8771 which while fixed, could revert again.

comment:9 Changed 6 years ago by Don-vip

Ticket #11131 has been marked as a duplicate of this ticket.

comment:10 Changed 5 years ago by simon04

Resolution: fixed
Status: newclosed

In 9514/josm:

fix #4003 fix #7004 fix #8149 - Improve changeset tags handling (from earlier changeset, from dataset)

comment:11 Changed 5 years ago by simon04

Milestone: 16.02

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.