Modify

Opened 7 years ago

Closed 21 months ago

#7757 closed defect (fixed)

AIOOBE at RoutePatternAction.calcOffset

Reported by: anders@… Owned by: roland.olbricht
Priority: critical Milestone:
Component: Plugin public_transport Version: tested
Keywords: ArrayIndexOutOfBoundsException Cc:

Description

What steps will reproduce the problem?

  1. Open the public_transport plugin
  2. Open Route pattens
  3. Dubble click on "Bus 376: Henån[ID] 21885015"

What happens instead?

You get a nice crash dump. It might be related to all of the route isn't loaded.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-06-04 01:31:02
Last Changed Author: simon04
Revision: 5267
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-06-03 22:21:06 +0200 (Sun, 03 Jun 2012)
Last Changed Rev: 5267

Identification: JOSM/1.5 (5267 en)
Memory Usage: 69 MB / 247 MB (24 MB allocated, but free)
Java version: 1.7.0_04, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: DirectDownload (28412)
Plugin: DirectUpload (28412)
Plugin: buildings_tools (28412)
Plugin: download_along (28412)
Plugin: imageryadjust (28412)
Plugin: openstreetbugs (28412)
Plugin: public_transport (28412)
Plugin: routes (28412)

java.lang.ArrayIndexOutOfBoundsException: -1
	at java.util.Vector.elementData(Unknown Source)
	at java.util.Vector.elementAt(Unknown Source)
	at public_transport.RoutePatternAction.calcOffset(RoutePatternAction.java:2134)
	at public_transport.RoutePatternAction.fillStoplistTable(RoutePatternAction.java:2154)
	at public_transport.RoutePatternAction.routesSelectionChanged(RoutePatternAction.java:2096)
	at public_transport.RoutePatternAction.access$000(RoutePatternAction.java:60)
	at public_transport.RoutePatternAction$RoutesLSL.valueChanged(RoutePatternAction.java:72)
	at javax.swing.JList.fireSelectionValueChanged(Unknown Source)
	at javax.swing.JList$ListSelectionHandler.valueChanged(Unknown Source)
	at javax.swing.DefaultListSe

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by Don-vip

Ticket #7965 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by Don-vip

Ticket #10027 has been marked as a duplicate of this ticket.

comment:3 Changed 2 years ago by Don-vip

Ticket #13801 has been marked as a duplicate of this ticket.

comment:4 Changed 2 years ago by Don-vip

Summary: ArrayIndexOutOfBoundsException opening a bus routeAIOOBE at RoutePatternAction.calcOffset

comment:5 Changed 2 years ago by Don-vip

Ticket #14914 has been marked as a duplicate of this ticket.

comment:6 Changed 21 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33767:33769].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain roland.olbricht.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.