Modify

Opened 5 years ago

Closed 5 years ago

#10027 closed defect (duplicate)

public_transport plugin crash

Reported by: molind@… Owned by: roland.olbricht
Priority: normal Milestone:
Component: Plugin public_transport Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. File -> Download from OSM -> Download area with routes (West of Minsk)
  2. Public Transport -> Route patterns -> Select any pattern (116)
  3. It's crashed

What is the expected result?

Not crashing.

What happens instead?

It's crashed. :)

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-04-25 17:49:40
Last Changed Author: Don-vip
Revision: 7000
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-04-25 19:46:38 +0200 (Fri, 25 Apr 2014)
Last Changed Rev: 7000

Identification: JOSM/1.5 (7000 en) Mac OS X 10.9.2
Memory Usage: 228 MB / 1820 MB (145 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.util.Arrays.useLegacyMergeSort=true, -Xbootclasspath/a:/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/lib/javaws.jar:/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/lib/deploy.jar:/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/lib/plugin.jar, -Djnlpx.vmargs=-Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.jvm=<java.home>/bin/java, -Djnlpx.splashport=-1, -Djnlpx.home=/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=/var/folders/hb/sktx4d5x2q115d8b54k4y8p80000gn/T/session1730118287227141067, -Djnlpx.heapsize=NULL,NULL, -Djava.security.policy=file:/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/lib/security/javaws.policy, -DtrustProxy=true, -Xverify:remote, -Dsun.awt.warmup=true]
Dataset consistency test: No problems found

Plugin: public_transport (30413)
Plugin: undelete (30413)

java.lang.ArrayIndexOutOfBoundsException: -1
	at java.util.Vector.elementData(Vector.java:730)
	at java.util.Vector.elementAt(Vector.java:473)
	at public_transport.RoutePatternAction.calcOffset(RoutePatternAction.java:2128)
	at public_transport.RoutePatternAction.fillStoplistTable(RoutePatternAction.java:2148)
	at public_transport.RoutePatternAction.routesSelectionChanged(RoutePatternAction.java:2090)
	at public_transport.RoutePatternAction.access$000(RoutePatternAction.java:55)
	at public_transport.RoutePatternAction$RoutesLSL.valueChanged(RoutePatternAction.java:67)
	at javax.swing.JList.fireSelectionValueChanged(JList.java:1798)
	at javax.swing.JList$ListSelectionHandler.valueChanged(JList.java:1812)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:184)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:164)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:211)
	at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:405)
	at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:415)
	at javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:459)
	at javax.swing.JList.setSelectionInterval(JList.java:2067)
	at javax.swing.plaf.basic.BasicListUI$Handler.adjustSelection(BasicListUI.java:2739)
	at javax.swing.plaf.basic.BasicListUI$Handler.mousePressed(BasicListUI.java:2695)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280)
	at java.awt.Component.processMouseEvent(Component.java:6502)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3320)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4489)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by anonymous

Component: CorePlugin public_transport
Owner: changed from team to roland.olbricht

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7757.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain roland.olbricht.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.