Modify

Opened 10 years ago

Closed 8 years ago

#7746 closed defect (fixed)

wrong style applied to ways

Reported by: Cobra Owned by: team
Priority: normal Milestone: 14.01
Component: Internal mappaint style Version: latest
Keywords: Cc:

Description

There are some cases in which a wrong style is applied to a way.

  • highway=service with tracktype=grade1 => appears as highway=track
  • highway=cycleway with tunnel=no => appears as highway=road(!)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by mrwojo

We could set the tracktype=grade1 style to a priority below most things but above highway=track. Thus a highway=service with grade1 would render as highway=service, while highway=track with grade1 would render as tracktype=grade1.


tunnel=no is rendered as a "deprecated" object like highway=road, bridge=no, cutting=no, embankment=no, shop=groceries, and mountain_pass=yes (when used on a way).

  1. Should the style specify rules exclusively to make tags appear deprecated? It's a task better suited to the validator.
  2. Is it clear that red dashes mean the thing has a deprecated tag? Probably not, given this bug and #6039 (it looks like boundary=administrative).
  3. Is it worth having a rule for the nearly unused shop=groceries?

comment:2 Changed 8 years ago by Don-vip

Milestone: 14.01
  • tracktype/grade1: cannot reproduce must have been fixed
  • tunnel=no, bridge=no, cutting=no, embankment=no, mountain_pass=yes => ok, styles removed
  • highway=road -> removed dashes to avoid ambiguity of #6039
  • shop=groceries => Old stuff, rule removed

comment:3 Changed 8 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6709/josm:

fix #6039, fix #7746:

  • highway=road when tagged looked like boundary=administrative
  • wrong style applied to ways for deprecated tags

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.