Modify

Opened 7 years ago

Closed 7 years ago

#7648 closed defect (fixed)

GPS-Download in JOSM in specific area not possible

Reported by: okilimu Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. download only gps-raw data with this url: http://api.openstreetmap.org/api/0.6/trackpoints?bbox=10.038045799999999,49.7493614,10.0412616,49.750925599999995&page=0
  2. or look at public track http://api.openstreetmap.org/user/CornyJoe/traces/1209300
  3. in <des> there is a german eszet with code 001A, which cause the parser in JOSM to fail load gps data

What is the expected result? gps data cannot be used in JOSM

What happens instead? missing gps data

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-04-23 01:31:02
Last Changed Author: simon04
Revision: 5204
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-04-22 11:33:19 +0200 (Sun, 22 Apr 2012)
Last Changed Rev: 5204

Identification: JOSM/1.5 (5204 de)
Memory Usage: 508 MB / 508 MB (62 MB allocated, but free)
Java version: 1.6.0_14, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: FixAddresses (27907)
Plugin: ImportImagePlugin (27906)
Plugin: OpeningHoursEditor (27852)
Plugin: PicLayer (27883)
Plugin: RoadSigns (27868)
Plugin: buildings_tools (27984)
Plugin: licensechange (27964)
Plugin: openstreetbugs (27852)
Plugin: tageditor (27869)
Plugin: turnrestrictions (27891)
Plugin: walkingpapers (27649)

org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException: An invalid XML character (Unicode: 0x1a) was found in the element content of the document.
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:91)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$DownloadTask.realRun(DownloadGpsTask.java:99)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concu

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by Don-vip

I have created a ticket on OSM Trac: #osm4382.

comment:2 Changed 7 years ago by simon04

Ticket #7866 has been marked as a duplicate of this ticket.

comment:3 Changed 7 years ago by anonymous

Ticket #7919 has been marked as a duplicate of this ticket.

comment:4 Changed 7 years ago by Don-vip

Ticket #8063 has been marked as a duplicate of this ticket.

comment:5 Changed 7 years ago by bastiK

Ticket #8603 has been marked as a duplicate of this ticket.

comment:6 Changed 7 years ago by bastiK

Resolution: fixed
Status: newclosed

In 5854/josm:

fixed #7648 - GPS-Download in JOSM in specific area not possible

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.