Modify

Opened 9 years ago

Closed 9 years ago

#8063 closed defect (duplicate)

Downloading raw GPS-Data fails

Reported by: n.wuest@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. I wanted to download some Data from OSM-Server including Raw GPS-Data. I selected an area near Wachenroth in Germany (Data between Wachenroth and Weingarsgreuth)
  2. Downloading the OSM-Data finished successfully.

What is the expected result?
Downloading all GPS-Tracks in the selected area

What happens instead?
Error occured. On a Linux-System i found some hints about illegal characters in the gpx-files

The error occures also an Windows-Systems.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-08-31 01:31:11
Last Changed Author: Don-vip
Revision: 5485
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-08-31 00:21:56 +0200 (Fri, 31 Aug 2012)
Last Changed Rev: 5485

Identification: JOSM/1.5 (5485 en)
Memory Usage: 80 MB / 494 MB (28 MB allocated, but free)
Java version: 1.7.0_07, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: ElevationProfile (28150)
Plugin: FastDraw (28656)
Plugin: colorscheme (28656)
Plugin: editgpx (28689)
Plugin: merge-overlap (28656)
Plugin: openvisible (28656)

org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException; lineNumber: 3940; columnNumber: 22; An invalid XML character (Unicode: 0x1a) was found in the element content of the document.
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:91)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$DownloadTask.realRun(DownloadGpsTask.java:99)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPo

Attachments (1)

Selection.png (373.9 KB) - added by n.wuest@… 9 years ago.
Selection

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by n.wuest@…

Attachment: Selection.png added

Selection

comment:1 Changed 9 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7648.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.