Modify

Opened 12 years ago

Closed 12 years ago

#7557 closed defect (fixed)

ID# shown twice in middle click selection window

Reported by: rickmastfan67 Owned by: team
Priority: trivial Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

This is happening all the time when you middle click on a way/node as long as you have the "Show object ID in selection lists" option turned on. If you turn off it off, the ID# only shows up once in the middle click window.

Steps to reproduce:

  1. F12 to go into settings
  2. Display Settings > Look and Feel > "Show object ID in selection lists" (activate it if it isn't already)
  3. Download some data from the OSM server.
  4. Once data is loaded, hover your mouse over any way/node and click the middle button on your mouse.

What happens:
In the window that shows up after middle clicking, you see the ID# of the way/node show up twice (once with commas, once without).

What should happen:
You should only see the ID# of the way once in the middle click window. Either the ID# using commas, or without using commas should just be displayed instead of both (with the "show ID#" option turned off, only the non-comma version is shown).

Eliminating one of the two ID#'s in the middle click window could help save some space. Sometimes in the box that is displayed after you middle click, if the name of the item is longer than all of the other tags for the item, you have excess space wasted because of the dual ID#'s.


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-03-29 01:32:44
Last Changed Author: jttt
Revision: 5127
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-03-28 20:30:52 +0200 (Wed, 28 Mar 2012)
Last Changed Rev: 5127

Identification: JOSM/1.5 (5127 en)
Memory Usage: 122 MB / 2730 MB (83 MB allocated, but free)
Java version: 1.6.0_31, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Plugin: OpeningHoursEditor (27852)
Plugin: buildings_tools (27984)
Plugin: licensechange (27964)
Plugin: mapdust (27884)
Plugin: measurement (27957)
Plugin: openstreetbugs (27852)
Plugin: reverter (28089)
Plugin: turnrestrictions (27891)
Plugin: undelete (27852)
Plugin: utilsplugin2 (28045)

Attachments (1)

dupIDmiddle.png (12.5 KB ) - added by rickmastfan67 12 years ago.

Download all attachments as: .zip

Change History (2)

by rickmastfan67, 12 years ago

Attachment: dupIDmiddle.png added

comment:1 by akks, 12 years ago

Resolution: fixed
Status: newclosed

In 5129/josm:

fix #7557: ID# shown twice in middle click selection window

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.