Modify

Opened 11 years ago

Closed 9 years ago

#7556 closed enhancement (duplicate)

Introducing chuks of settings in Presets

Reported by: Pedja Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: preset chunk Cc:

Description

While creating Presets I stumbled into an issue: number of presets share the same tag structure, and I have to repat the same structure again and again. Problem occures if there is need to change structure because one must go all way down through presets and make changes in each of them.

It would be good to have something like a chunk or subpreset, which is defined by name and contains definitions for part of preset, whole preset or even several presets. Then new preset item called <chunk> or <subpreset> could be used to mark where in definition chunk has to be inserted.

Result would be that we could define structure in one place and reuse it in several places.

This could also help in reusing presets in seveal groups. For example, if I have group for traffic objects and group for mountainbiking objects, both groups could share some of the presets so one who edits map does not have to look through all preset definitions as ones he needs for specific type of mapping are kept together.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by skyper

Component: External presetCore
Keywords: preset chunk added

comment:2 Changed 9 years ago by simon04

A possible implementation (already containing a patch) is being discussed in #9327.

comment:3 Changed 9 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9327.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.