Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7558 closed defect (fixed)

History window shows XML entities in user names

Reported by: kolen Owned by: team
Priority: trivial Milestone:
Component: Core Version: tested
Keywords: history, entities, entity Cc:

Description

If user name contain characters such as apostrophe ('), history window shows such characters as XML entity, i.e. "'".

version 5047

Attachments (1)

josm-history-entities-in-names.png (118.4 KB) - added by kolen 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by kolen

comment:1 Changed 7 years ago by Don-vip

I can reproduce it with:

Build-Date: 2012-03-31 00:15:59
Revision: 5137
Is-Local-Build: true

Identification: JOSM/1.5 (5137 SVN en)
Memory Usage: 154 MB / 1816 MB (118 MB allocated, but free)
Java version: 1.7.0_02, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Can you post you system information, please ? (first lines of Help->Status report).

@team: This change has been intentionally made in r4602:
http://josm.openstreetmap.de/changeset/4602/josm#file7 (line 444)

But I don't understand why the HTML entities are not replaced. Is it a LnF-specific bug ?

comment:2 Changed 7 years ago by bastiK

Resolution: fixed
Status: newclosed

I've committed a fix, but it doesn't show up in trac...

comment:3 Changed 7 years ago by Don-vip

r5146 :) Are you sure it does only concern the apostrophe sign ?

comment:4 Changed 7 years ago by bastiK

Yes, I've tried all except \t \n and \r. My Java is

java version "1.6.0_23"
OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre11-0ubuntu1.11.10.2)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

comment:5 Changed 7 years ago by Don-vip

FYI I have created a bug on bugs.sun.com:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7158257

It has been closed as "not a defect" because Java supports only HTML 3.2, but "apos;" is not even in HTML 4. Indeed, it appeared only in XHTML 1.0: http://en.wikipedia.org/wiki/List_of_XML_and_HTML_character_entity_references#Character_entity_references_in_HTML

This wikipedia list is useful to find entities not supported by Java (everything introduced after HTML 3.2). I will run some tests and maybe add some other exceptions.

Last edited 7 years ago by Don-vip (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.