Modify

Opened 8 years ago

Closed 8 years ago

#7470 closed defect (fixed)

[Patch] Annoying warning about deleting nodes with id:0 outside BBox

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I get warnings about deleting nodes with id:0 outside BBox.

There should be no warning as you can not delete any incomplete object by deleting a node with id:0

r5033

Attachments (2)

outside_BBox_sample.osm.bz2 (629 bytes) - added by skyper 8 years ago.
sample
7470.patch (4.5 KB) - added by simon04 8 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by simon04

Please attach a test file, I cannot reproduce (1. download some area, 2. add a node outside the area, 3. delete this node).

comment:2 in reply to:  1 ; Changed 8 years ago by skyper

Replying to simon04:

Please attach a test file, I cannot reproduce (1. download some area, 2. add a node outside the area, 3. delete this node).

Sorry not much time right now:

Please, try it with a way id:0.

Thanks

comment:3 in reply to:  2 Changed 8 years ago by skyper

Replying to skyper:

Replying to simon04:

Please attach a test file, I cannot reproduce (1. download some area, 2. add a node outside the area, 3. delete this node).

Sorry not much time right now:

I had five minutes !

Sorry my description is incomplete.

  1. download an closed way with at least one node outside BBox
  2. use terracer to terrace keeping the original way
  3. delete the new created closed way with the node outside BBox

It has to due with ways. I gonna attach an example.

Changed 8 years ago by skyper

Attachment: outside_BBox_sample.osm.bz2 added

sample

Changed 8 years ago by simon04

Attachment: 7470.patch added

comment:4 Changed 8 years ago by simon04

Summary: Annoying warning about deleting nodes with id:0 outside BBox[Patch] Annoying warning about deleting nodes with id:0 outside BBox

The attached patch should take care of this issue. Patch explained in words: As the delete operation already takes care of including/excluding way-nodes from deletion, there is no need to check ways in the outlying check.

To be on the safe side, I'd await the end of stabilization phase although I do not expect any problems with the patch.

comment:5 Changed 8 years ago by simon04

Ticket #7080 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In 5060/josm:

fix #7470 - tune warning of nodes out of downloaded bbox

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.