Modify

Opened 7 years ago

Closed 7 years ago

#7471 closed defect (fixed)

No suitable download task for XAPI queries with * for object type

Reported by: ToeBee Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc: ToeBee

Description

Just updated to r5036 to test this although this has been a problem for a few weeks now.

Trying to download this URL from my private jXAPI instance fails:
http://localhost:8080/xapi/api/0.6/*[name=Applebees]

with the error message:
"Cannot open URL [...] because no suitable download task is available"

The problem is the regex in DownloadOsmTask.acceptsUrl() on line 82. It works fine for node/way/relation queries but not for * which is a valid XAPI style query.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5044/josm:

fix #7471 - No suitable download task for XAPI queries with * for object type

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.