Modify

Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#7363 closed defect (fixed)

caching bug with aerial imagery

Reported by: dieterdreist Owned by: team
Priority: normal Milestone: 15.08
Component: Core imagery Version: latest
Keywords: wms cache Cc: A_Pirard

Description

due to network problems I noticed (supposedly) a caching bug: I added an aerial imagery layer (wms) while being offline: the tiles were displayed (guess from the cache), but after a few seconds, the same tiles became red (the already downloaded tiles). "Automatic downloading" is activated (is this the reason that already present tiles will get re-requested?). Red tiles should be omitted if there is some image in cache for the area.

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by skyper

Component: CoreCore imagery

comment:2 Changed 6 years ago by skyper

Keywords: cache added; imagery removed

comment:3 Changed 6 years ago by A_Pirard

I didn't know that this bug report existed when I wrote the following, another phrasing, to which I add "reproducing":
I often notice with an often non-responding server that JOSM doesn't use its WMS cache.
If one is returning to previous work when the server no longer responds, WMS first displays previously cached tiles, then it probably sends requests that time out for the same tiles and it ends up painting them in red after a delay. That's how it looks like.
That is of course frustrating to see the map eased and that one could but cannot finish some work because of that.

Reproducing:
Load an OSM area and open a WMS layer.
Close and restart JOSM.
Reload the same OSM area.
Disconnect the Internet (e.g. shutdown WiFi or sudo route add default gw 127.0.0.2 (restore later: sudo route del default gw 127.0.0.2))
Reopen the same WMS layer: tiles appear and then turn to red after a timeout.
Cheers.

Last edited 5 years ago by A_Pirard (previous) (diff)

comment:4 Changed 6 years ago by A_Pirard

Cc: A_Pirard added

comment:5 Changed 5 years ago by wiktorn

Milestone: 15.06

comment:6 Changed 5 years ago by Don-vip

Milestone: 15.0615.07

skip milestone 15.06

comment:7 Changed 5 years ago by wiktorn

Resolution: fixed
Status: newclosed

In 8526/josm:

Introduce WMS layer based on TMS. (closes: #11255)

HEADS UP: After this patch you need to manually remove JAX-B generated file/class: org/w3/_2001/xmlschema/Adapter1.java to compile the tree again.

  • create AbstractTileSourceLayer based on TMSLayer as a base for TMS, WMS and (future) WMTS layers, (addresses #11459)
  • WMS layer now uses JCS Caching (closes: #7363)
  • introduce new conversion methods in TileSource, that convert both X and Y (lat and lon) in one call. This is necessary for other than PseudoMercator projections
    • introduce TileXY class that represents X and Y indexes of tile in tile matrix/space
    • mark old conversion methods as deprecated
    • refactor JMapViewer and JOSM to new methods
    • change use of Coordinate class to ICoordinate where appropiate
  • extract CachedAttributionBingAerialTileSource to separate file
  • create TemplatedWMSTileSource that provides the WMS Layer with square (according to current projection) tiles (closes: #11572, closes: #7682, addresses: #5454)
  • implemented precaching imagery along GPX track for AbstractTileSourceLayer, so now it work for both - WMS and TMS (closes: #9154)
  • implemented common righ-click menu on map view, as well on layer list (closes #3591)
  • create separate build commands for JMapViewer classes to easily spot, when josm classes are used within JMapViewer
  • remove unnecessary classes of previous WMS implementation - GeorefImage, wms-cache.xsd (and JAXB task from build), WMSCache, WMSRequest, WMSGrabber, HTMLGrabber, WMSException

comment:8 Changed 5 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.