Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7179 closed defect (duplicate)

Bug

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-24 02:32:07
Last Changed Author: simon04
Revision: 4707
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-24 00:26:04 +0100 (Sat, 24 Dec 2011)
Last Changed Rev: 4707

Identification: JOSM/1.5 (4707 ru)
Memory Usage: 487 MB / 487 MB (423 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: DirectUpload (27178)
Plugin: FastDraw (27178)
Plugin: FixAddresses (27178)
Plugin: ImproveWayAccuracy (27178)
Plugin: OpeningHoursEditor (27178)
Plugin: PicLayer (27296)
Plugin: RoadSigns (27241)
Plugin: buildings_tools (27119)
Plugin: dataimport (26731)
Plugin: download_along (27119)
Plugin: editgpx (27038)
Plugin: ext_tools (27119)
Plugin: gpxfilter (27178)
Plugin: imageryadjust (27178)
Plugin: importvec (27119)
Plugin: licensechange (27241)
Plugin: measurement (26731)
Plugin: namemanager (26731)
Plugin: native_password_manager (27241)
Plugin: openstreetbugs (27119)
Plugin: openvisible (26731)
Plugin: pbf (27241)
Plugin: reltoolbox (27241)
Plugin: restart (26731)
Plugin: reverter (27159)
Plugin: tag2link (27304)
Plugin: tageditor (27178)
Plugin: tagging-preset-tester (27178)
Plugin: turnlanes (26731)
Plugin: turnrestrictions (27241)
Plugin: undelete (27243)
Plugin: utilsplugin2 (27241)
Plugin: waydownloader (27241)

java.lang.NullPointerException: Случилась беда: не удалось обнаружить изображение 'empty.???'. Это серьёзная проблема конфигурации. JOSM прекращает работу.

at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:89)
at org.openstreetmap.josm.plugins.taggingpresettester.TaggingCellRenderer.getListCellRendererComponent(TaggingCellRenderer.java:38)
at javax.swing.plaf.basic.BasicComboBoxUI.getDisplaySize(BasicComboBoxUI.java:1334)
at javax.swing.plaf.metal.MetalComboBoxUI.getMinimumSize(MetalComboBoxUI.java:316)
at javax.swing.plaf.basic.BasicComboBoxUI.getPreferredSize(BasicComboBoxUI.java:892)
at javax.swing.JComponent.getPreferredSize(JComponent.java:1634)
at java.awt.BorderLayout.layoutContainer(BorderLayout.java:798)
at java.awt.Container.layout(Container.java:1421)
at java.awt.Container.doLayout(Container.java:1410)
at java.awt.Container.validateTree(Container.java:1507)
at java.awt.Container.validateTree(Container.java:1513)
at java.awt.Container.validateTree(Container.java:1513)
at java.awt.Container.validateTree(Container.java:1513)
at java.awt.Container.validate(Container.java:1480)
at java.awt.Window.show(Window.java:861)
at java.awt.Component.show(Component.java:1584)
at java.awt.Component.setVisible(Component.java:1536)
at java.awt.Window.setVisible(Window.java:842)
at org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTester.<init>(TaggingPresetTester.java:86)
at org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTesterAction.actionPerformed(TaggingPresetTesterAction.java:49)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:809)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:850)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
at java.awt.Component.processMouseEvent(Component.java:6288)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:6053)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4651)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4481)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4481)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:643)
at java.awt.EventQueue.access$000(EventQueue.java:84)
at java.awt.EventQueue$1.run(EventQueue.java:602)
at java.awt.EventQueue$1.run(EventQueue.java:600)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
at java.awt.EventQueue$2.run(EventQueue.java:616)
at java.awt.EventQueue$2.run(EventQueue.java:614)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:613)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by skyper

Please, describe step by step what you did and how to reproduce this error.

Did you try it without plugins and with a new/empty preferences directory ?
Have a look at Help/ResetPreferences and InstallNotes ( most of the MacOS part is also valid for Linux)

You could also try it with openjdk instead of oracle/sun java.

I noticed that all memory is allocated. I sometimes get strange behaviour when JOSM runs out of memory. Maybe raise the amount of memory with:

quoted:

java -Xmx256M -jar FOLDER/josm-latest.jar

This would allow JOSM to use up to 256 MB of RAM (memory). The java option "-Xmx256M" set's the maximum Java heap size to 265 MB. You are free to replace -Xmx256M by any number appropriate for your system (e.g. -Xmx512M or even -Xmx1024M).
end of quote

  • On old machines I even set 200MB but only load little data to edit.
  • On a desktop system with 4GB RAM and not many running background processes you can set it to 2048MB and you will notice some gain in performance.

comment:2 Changed 9 years ago by skyper

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by skyper

Closed as duplicate of #6795.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.