Modify

Opened 8 years ago

Closed 8 years ago

#6795 closed defect (fixed)

Ошибека анализатора тегов

Reported by: eaglex@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Данная ошибка появляется при запуске анализатора заготовок тегов. Перед этип появляются 3 сообщения:

  1. "Ошибка при разборе resource://data/defaultpresets.xml: cvc-enumeration-valid: Value "is not faced-valid with respect to enumeration '[on, off]'. It must be a value from the enumeration. (строка 1 451, столбец 102)"
  1. "Ошибка при разборе http://www.asamnet.de/~fischept/osm/oepnv_preset.xml: cvc-complex-type.3.2.2: Attribute 'values' is not allowed to appear in element 'key' (строка 153, столбец 49)"
  1. "Ошибка при разборе http://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1: Attribute "value" was already specified for element "key""

Ошибка 3 появляется и при запуске программы.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-09-05 01:31:49
Last Changed Author: bastiK
Revision: 4399
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-09-04 22:13:51 +0200 (Sun, 04 Sep 2011)
Last Changed Rev: 4399

Identification: JOSM/1.5 (4399 ru)
Memory Usage: 32 MB / 494 MB (5 MB allocated, but free)
Java version: 1.6.0_25, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP

Plugin: Curves (16.master-4f7c5a0)
Plugin: FastDraw (26606)
Plugin: ImproveWayAccuracy (26610)
Plugin: OpeningHoursEditor (26606)
Plugin: PicLayer (26606)
Plugin: alignways (26606)
Plugin: contourmerge (1003)
Plugin: editgpx (26606)
Plugin: imageryadjust (26606)
Plugin: multipoly-convert (26606)
Plugin: namemanager (26606)
Plugin: openstreetbugs (26606)
Plugin: openvisible (26606)
Plugin: osmarender (26606)
Plugin: public_transport (26606)
Plugin: reltoolbox (26606)
Plugin: restart (26606)
Plugin: tagging-preset-tester (26606)
Plugin: turnlanes (26606)
Plugin: turnrestrictions (26606)
Plugin: utilsplugin2 (26624)

java.lang.NullPointerException: Случилась беда: не удалось обнаружить изображение 'empty.???'. Это серьёзная проблема конфигурации. JOSM прекращает работу.

at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:81)
at org.openstreetmap.josm.plugins.taggingpresettester.TaggingCellRenderer.getListCellRendererComponent(TaggingCellRenderer.java:38)
at javax.swing.plaf.basic.BasicComboBoxUI.getDisplaySize(Unknown Source)
at javax.swing.plaf.basic.BasicComboBoxUI.getMinimumSize(Unknown Source)
at javax.swing.plaf.basic.BasicComboBoxUI.getPreferredSize(Unknown Source)
at com.sun.java.swing.plaf.windows.WindowsComboBoxUI.getPreferredSize(Unknown Source)
at javax.swing.JComponent.getPreferredSize(Unknown Source)
at java.awt.BorderLayout.layoutContainer(Unknown Source)
at java.awt.Container.layout(Unknown Source)
at java.awt.Container.doLayout(Unknown Source)
at java.awt.Container.validateTree(Unknown Source)
at java.awt.Container.validateTree(Unknown Source)
at java.awt.Container.validateTree(Unknown Source)
at java.awt.Container.validateTree(Unknown Source)
at java.awt.Container.validate(Unknown Source)
at java.awt.Window.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTester.<init>(TaggingPresetTester.java:86)
at org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTesterAction.actionPerformed(TaggingPresetTesterAction.java:49)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$000(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by stoecker

In [4402/josm]:

see #6795 - fix point 1

comment:2 Changed 8 years ago by stoecker

Point 3 fixed as well.

comment:3 Changed 8 years ago by stoecker

For Point 2 the author of external preset needs to be contacted.

comment:4 Changed 8 years ago by skyper

Ticket #7179 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by jttt

In [4726/josm]:

Fix exception handling (xml file not valid against xsd can't cause RuntimeException, see #6795), remove unused inner class

comment:6 Changed 8 years ago by jttt

Resolution: fixed
Status: newclosed

I guess main complain was that invalid xml file caused exception - that is fixed, now it shows only warning dialog again. So closing..

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.