Modify

Opened 7 years ago

Closed 7 years ago

#7180 closed defect (fixed)

Bug

Reported by: anonymous Owned by: bastiK
Priority: normal Milestone:
Component: Plugin native_password_manager Version: tested
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-24 02:32:07
Last Changed Author: simon04
Revision: 4707
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-24 00:26:04 +0100 (Sat, 24 Dec 2011)
Last Changed Rev: 4707

Identification: JOSM/1.5 (4707 ru)
Memory Usage: 487 MB / 487 MB (407 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: DirectUpload (27178)
Plugin: FastDraw (27178)
Plugin: FixAddresses (27178)
Plugin: ImproveWayAccuracy (27178)
Plugin: OpeningHoursEditor (27178)
Plugin: PicLayer (27296)
Plugin: RoadSigns (27241)
Plugin: buildings_tools (27119)
Plugin: dataimport (26731)
Plugin: download_along (27119)
Plugin: editgpx (27038)
Plugin: ext_tools (27119)
Plugin: gpxfilter (27178)
Plugin: imageryadjust (27178)
Plugin: importvec (27119)
Plugin: licensechange (27241)
Plugin: measurement (26731)
Plugin: namemanager (26731)
Plugin: native_password_manager (27241)
Plugin: openstreetbugs (27119)
Plugin: openvisible (26731)
Plugin: pbf (27241)
Plugin: reltoolbox (27241)
Plugin: restart (26731)
Plugin: reverter (27159)
Plugin: tag2link (27304)
Plugin: tageditor (27178)
Plugin: tagging-preset-tester (27178)
Plugin: turnlanes (26731)
Plugin: turnrestrictions (27241)
Plugin: undelete (27243)
Plugin: utilsplugin2 (27241)
Plugin: waydownloader (27241)

java.lang.AbstractMethodError: org.openstreetmap.josm.plugins.npm.NPMCredentialsAgent.lookup(Ljava/net/Authenticator$RequestorType;Ljava/lang/String;)Ljava/net/PasswordAuthentication;

at org.openstreetmap.josm.io.auth.CredentialsManager.lookup(CredentialsManager.java:89)
at org.openstreetmap.josm.gui.preferences.server.ProxyPreferencesPanel.initFromPreferences(ProxyPreferencesPanel.java:327)
at org.openstreetmap.josm.gui.preferences.server.ProxyPreferencesPanel.<init>(ProxyPreferencesPanel.java:368)
at org.openstreetmap.josm.gui.preferences.ServerAccessPreference.buildTabbedServerPreferences(ServerAccessPreference.java:61)
at org.openstreetmap.josm.gui.preferences.ServerAccessPreference.buildContentPanel(ServerAccessPreference.java:95)
at org.openstreetmap.josm.gui.preferences.ServerAccessPreference.addGui(ServerAccessPreference.java:111)
at org.openstreetmap.josm.gui.preferences.PreferenceTabbedPane.buildGui(PreferenceTabbedPane.java:244)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.build(PreferenceDialog.java:51)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.<init>(PreferenceDialog.java:64)
at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:38)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:34)
at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1639)
at javax.swing.JComponent.processKeyBinding(JComponent.java:2851)
at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:267)
at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:229)
at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2928)
at javax.swing.JComponent.processKeyBindings(JComponent.java:2920)
at javax.swing.JComponent.processKeyEvent(JComponent.java:2814)
at java.awt.Component.processEvent(Component.java:6065)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4651)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4481)
at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1850)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:712)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:990)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:855)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:676)
at java.awt.Component.dispatchEventImpl(Component.java:4523)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4481)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:643)
at java.awt.EventQueue.access$000(EventQueue.java:84)
at java.awt.EventQueue$1.run(EventQueue.java:602)
at java.awt.EventQueue$1.run(EventQueue.java:600)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
at java.awt.EventQueue$2.run(EventQueue.java:616)
at java.awt.EventQueue$2.run(EventQueue.java:614)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:613)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by stoecker

Component: CorePlugin native_password_manager
Owner: changed from team to bastiK

Caused by my update of password stuff to support a host name in arguments. Plugin must be adapted to match the new arguments. Probably also storage must be changed to be aware of host name.

comment:2 Changed 7 years ago by stoecker

Plugin does not compile.

I fixed this in [o27367], but did not test it.

comment:3 Changed 7 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.