Modify

Opened 8 years ago

Closed 3 years ago

#7099 closed enhancement (fixed)

Detecting the correct traffic flow at roundabouts

Reported by: anonymous Owned by: team
Priority: normal Milestone: 16.02
Component: Core validator Version:
Keywords: flow traffic direction roundabout Cc: naoliv

Description

To avoid errors in flow at roundabouts JOSM should take into account the direction of traffic (right- and left-hand traffic) through:

  • Detecting the traffic flow depending on country or area that the user is editing on the map,
  • Or capturing the locale and/or language of the operating system.

Currently this issue is a significant source of errors among users, which in drawing the roundabout does not take into account the proper traffic flow when they digitize it.

Attachments (1)

falsepositive.osm (6.5 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by simon04

Component: CoreCore validator

comment:2 Changed 4 years ago by simon04

In 9540/josm:

see #7099 - Validate correct traffic flow at roundabouts

Changed 4 years ago by simon04

Attachment: falsepositive.osm added

comment:3 Changed 4 years ago by simon04

Milestone: 16.02

When the roundabout is not mapped as a closed way, but with fragments, this might lead to false-positives such as in attachment:falsepositive.osm

Shall we handle this somehow?

comment:4 Changed 4 years ago by aceman

I'd be grateful if you could detect split roundabouts correctly.

On the other hands, I have encountered straight roads INCORRECTLY tagged as roundabout. It would be great if JOSM did detect that (that the segments tagged junction=roundabout do not form a closed way). If that is for a new ticket I can file it.
Thanks.

comment:5 Changed 4 years ago by naoliv

Ticket #12289 has been marked as a duplicate of this ticket.

comment:6 Changed 4 years ago by naoliv

Cc: naoliv added

comment:7 Changed 3 years ago by Don-vip

Milestone: 16.0216.03

comment:8 Changed 3 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

comment:9 Changed 3 years ago by Don-vip

Milestone: 16.0416.05

comment:10 Changed 3 years ago by Don-vip

Milestone: 16.0516.06

comment:11 Changed 3 years ago by Don-vip

Milestone: 16.0616.02
Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.