Modify

Opened 8 years ago

Closed 8 years ago

#12289 closed enhancement (duplicate)

Test for reversed roundabouts in validator

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: roundabout Cc:

Description

Could we have a test (maybe at informational level, to avoid false positives) to warn about reversed junction=roundabout?

For example, JOSM should warn when a roundabout in a right-hand traffic place is clockwise or left-hand traffic is counter-clockwise.

Could use MapCSS's is_right_hand_traffic() possibly.

JOSM

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-04 01:48:44 +0100 (Mon, 04 Jan 2016)
Build-Date:2016-01-04 02:34:17
Revision:9299
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9299 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 514 MB / 9102 MB (372 MB allocated, but free)
Java version: 1.8.0_72-internal, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- RoadSigns (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- buildings_tools (31895)
- conflation (0.1.9)
- contourmerge (1014)
- download_along (31772)
- editgpx (31772)
- ejml (31895)
- geotools (31895)
- imagery_offset_db (31895)
- importvec (31772)
- jts (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31772)
- opendata (31924)
- pbf (31772)
- pdfimport (31895)
- poly (31772)
- reverter (31897)
- scripting (30722)
- todo (29154)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (31895)

Attachments (0)

Change History (1)

comment:1 by naoliv, 8 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7099.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.