Modify

Opened 8 years ago

Closed 5 years ago

#7021 closed defect (fixed)

Mac OS X compatibility (fullscreen, panning, scrolling, etc.)

Reported by: Vidar Gundersen Owned by: team
Priority: normal Milestone: 14.09
Component: Core Version: latest
Keywords: macosx fullscreen Cc: gobftald

Description

Some minor issues related to using JOSM on Mac OS X:

  • Entering fullscreen mode (it seems the native Java distribution from Apple doesn't has a bug in that it doesn't support the fullscreen functionality added to the OS).
  • Panning using Ctrl+Left/Right doesn't work because the OS now ties these shortcuts to switching between fullscreen apps.
  • Scrolling using two fingers is now reversed: Should JOSM provide an option to reverse zoom/scroll direction as Google Earth does?

Attachments (0)

Change History (11)

comment:1 Changed 8 years ago by bastiK

Is the fullscreen menu item still visible on Mac OS X?

comment:2 Changed 6 years ago by Don-vip

Ticket #8497 has been marked as a duplicate of this ticket.

comment:3 Changed 6 years ago by Zverikk

The only thing that bugged me is the absence of fullscreen mode. I don't pan with keyboard, and scrolling is in line with other mac apps.

comment:4 Changed 6 years ago by Don-vip

Summary: Mac OS X Lion compatibilityMac OS X compatibility (fullscreen, panning, scrolling, etc.)

comment:5 Changed 6 years ago by Don-vip

Ticket #9371 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by Don-vip

Cc: gobftald added

comment:7 Changed 6 years ago by Don-vip

Keywords: osx added; os x removed

comment:8 Changed 5 years ago by Don-vip

Keywords: macosx added; mac osx lion removed

comment:9 Changed 5 years ago by Don-vip

Keywords: fullscreen added; compatibility removed

Full screen is indeed now possible: http://stackoverflow.com/a/8693890/2257172

comment:10 Changed 5 years ago by Don-vip

Milestone: 14.09

comment:11 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7482/josm:

fix #7021 - enable fullscreen with OS X

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.