Modify

Opened 6 years ago

Closed 6 years ago

#9371 closed defect (duplicate)

map panning shortcuts in JOSM conflict with system standard functions (OSX)

Reported by: gobftald Owned by: gobftald
Priority: normal Milestone:
Component: Core Version:
Keywords: Shortcut redefining Cc:

Description

Maps: Move Shortcuts are among the most basic and most frequent functions in the User Interface of JOSM. They are defaulted to +arrow keys. But these key combinations are reserved in OXS Mac for important standard functions.

I've tried to redefine these keys in JOSM Preferences but it did not work. I've tried with the combinations of other function keys (like alt, Shift, Command) and with only the arrow keys themselves but they did not work. The only way I was able to remap them if I switch off OSX own default Shortcuts and use JOSM original/default ones. But as I mentioned it is more than inconvenient from the usecase of Mac point of view.

Please correct this error and make possible to redefine these Shortcuts in JOSM preference panel.

It would help JOSM Mac users relevantly and make their Map Editing significantly easier.

Thx, gobftald

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7021.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain gobftald.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.