Modify

Opened 11 years ago

Closed 11 years ago

#654 closed defect (duplicate)

Coding error when downloading data

Reported by: bert_muijtstege@… Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Whwn starting Josm with a area lower then zoomlevel 16
I get only nodes and a coding error.
startup with
'C:\WINDOWS\system32\java.exe -jar -Xmx1024M "C:\josm\josm-latest.jar" '

Error:

Path: josm
URL: http://www.openstreetmap.de/svn/josm
Repository Root: http://www.openstreetmap.de/svn/josm
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 581
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 581
Last Changed Date: 2008-03-09 16:34:31 +0100 (Sun, 09 Mar 2008)

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
... 4 more

Caused by: java.lang.NullPointerException

at org.openstreetmap.josm.data.osm.Node.realEqual(Node.java:56)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.mergeAfterId(MergeVisitor.java:232)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.genMerge(MergeVisitor.java:60)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.visit(MergeVisitor.java:79)
at org.openstreetmap.josm.data.osm.Node.visit(Node.java:41)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:191)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:49)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 in reply to:  description Changed 11 years ago by framm

Replying to bert_muijtstege@hotmail.com:

Whwn starting Josm with a area lower then zoomlevel 16

In what way are you starting Josm "with an area lower than zoomlevel 16". Are you giving command line parameters, if so, can you specify an example that leads to this problem.

comment:2 Changed 11 years ago by cartinus

Debian GNU/Linux "Lenny" with KDE and sun-java6-jre

Start JOSM by clicking on a .desktop file that contains:
java -jar -Xmx1024M /home/data/JOSM/josm-latest.jar

Click on the download link in the middle of the page.

Paste the following URL: http://www.openstreetmap.org/?lat=51.4825&lon=4.9556&zoom=14&layers=B0FT

Data gets downloaded, but the error as pasted below occurs. Only nodes are displayed.

Changing the zoomlevel has no effect, the error still occurs. Trying to download an area a bit further east works fine. Trying to download any area that contains (part of) bus line 132 results in the error. This bus line is contained in the relations #8447 and #8591. However dowloading them with "wget http://www.openstreetmap.org/api/0.5/relation/8591/full -O R8591.osm" results in files that can be displayed by JOSM without problems.

Path: josm
URL: http://www.openstreetmap.de/svn/josm
Repository Root: http://www.openstreetmap.de/svn/josm
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 587
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 587
Last Changed Date: 2008-03-21 01:24:05 +0100 (Fri, 21 Mar 2008)

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(EventQueue.java:997)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
... 4 more

Caused by: java.lang.NullPointerException

at org.openstreetmap.josm.data.osm.Node.realEqual(Node.java:56)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.mergeAfterId(MergeVisitor.java:232)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.genMerge(MergeVisitor.java:60)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.visit(MergeVisitor.java:79)
at org.openstreetmap.josm.data.osm.Node.visit(Node.java:41)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:191)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:49)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:199)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:177)
at java.awt.Dialog$1.run(Dialog.java:1039)
at java.awt.Dialog$3.run(Dialog.java:1091)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:1089)
at java.awt.Component.show(Component.java:1419)
at java.awt.Component.setVisible(Component.java:1372)
at java.awt.Window.setVisible(Window.java:801)
at java.awt.Dialog.setVisible(Dialog.java:979)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

comment:3 Changed 11 years ago by cartinus

I ran into this bug again with revision 593 when downloading http://www.openstreetmap.org/index.html?mlat=52.15369118770507&mlon=5.364401377782869&zoom=13
which is about a half country away from the place I previously encountered the problem.

I think ticket #611 is about the same problem.

comment:4 Changed 11 years ago by cartinus

Resolution: duplicate
Status: newclosed

Duplicate of ticket #611

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.