Modify

Opened 9 years ago

Closed 3 years ago

#6332 closed defect (fixed)

[Patch] After uploading new items to OSM, JOSM doesn't update the author of the item unless a force data update.

Reported by: rickmastfan67 Owned by: simon04
Priority: major Milestone: 16.08
Component: Core Version: latest
Keywords: Cc:

Description (last modified by Don-vip)

Steps to reproduce:

  1. Create a brand new way (or node).
  2. Upload it to the OSM database.
  3. Select the way (or node) in JOSM right after the upload has been completed.

What happens: When you either middle click on it, or try to view the author info in the author subwindow, it will not show the person's (you) screen name. It does show the way ID's brand new # just fine (on the middle click window).
Example: When you middle click it will say: "highway (6 nodes) [id=0000000]" with no User name after the way ID after the successful upload.

What should happen: Brand new items that you have uploaded to OSM via JOSM should show your screen name as well as the way # without having to "update" the data a second time.

Also, when you update an item that somebody else last edited/created, JOSM isn't updating the "user" info of that item unless you do the "update data" or "update selection" after you upload the "tweak".

Was with r4079.

Attachments (3)

problem.png (15.7 KB) - added by rickmastfan67 9 years ago.
Shows a brand new way lacking the "user" info right after upload
problem2.png (55.7 KB) - added by rickmastfan67 9 years ago.
Shows the "author" subwindow lacking the "user" info and still calling it a "new object" when it isn't.
6332.patch (999 bytes) - added by simon04 3 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 9 years ago by rickmastfan67

Description: modified (diff)

comment:2 Changed 9 years ago by rickmastfan67

Summary: After uploading new items to OSM, JOSM doesn't update the author of the item unless a force data update. (possible regression)(possible regression) After uploading new items to OSM, JOSM doesn't update the author of the item unless a force data update.

Changed 9 years ago by rickmastfan67

Attachment: problem.png added

Shows a brand new way lacking the "user" info right after upload

Changed 9 years ago by rickmastfan67

Attachment: problem2.png added

Shows the "author" subwindow lacking the "user" info and still calling it a "new object" when it isn't.

comment:3 Changed 9 years ago by rickmastfan67

I hope you guys can now understand what I was talking about in the main post now since I attached the images showing this problem.

comment:4 Changed 8 years ago by rickmastfan67

Keywords: regression added

comment:5 Changed 8 years ago by stoecker

Keywords: regression removed
Summary: (possible regression) After uploading new items to OSM, JOSM doesn't update the author of the item unless a force data update.After uploading new items to OSM, JOSM doesn't update the author of the item unless a force data update.

Very likely author information is not sent by server after upload and thus not merged with the data set. Problem is: where do we get user id and author name? Maybe create a new "<uploader>" user for this purpose?

comment:6 Changed 6 years ago by Don-vip

Ticket #9069 has been marked as a duplicate of this ticket.

comment:7 in reply to:  5 ; Changed 6 years ago by Don-vip

Description: modified (diff)

Replying to stoecker:

Problem is: where do we get user id and author name?

From a GET /api/0.6/changeset/#id ?

comment:8 in reply to:  7 Changed 6 years ago by skyper

Replying to Don-vip:

Replying to stoecker:

Problem is: where do we get user id and author name?

From a GET /api/0.6/changeset/#id ?

Strange, history even shows user name for local objects at least with OAuth and JOSM knows the user who is uploading e.g. it should set it as soon as the upload did succeed. Only the ids are needed the user should already be known.

comment:9 Changed 6 years ago by Don-vip

Because history makes a new API request, so all information is returned here.

comment:10 Changed 3 years ago by Don-vip

Ticket #13256 has been marked as a duplicate of this ticket.

Changed 3 years ago by simon04

Attachment: 6332.patch added

comment:11 Changed 3 years ago by simon04

Milestone: 16.08
Owner: changed from team to simon04
Status: newassigned
Summary: After uploading new items to OSM, JOSM doesn't update the author of the item unless a force data update.[Patch] After uploading new items to OSM, JOSM doesn't update the author of the item unless a force data update.

comment:12 Changed 3 years ago by Don-vip

patch can be applied :)

comment:13 Changed 3 years ago by simon04

Resolution: fixed
Status: assignedclosed

In 10818/josm:

fix #6332 - Update user and timestamp of OSM objects after upload

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.