Modify

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#6214 closed defect (invalid)

Plugins handling broken in 4021?

Reported by: dpaleino Owned by: team
Priority: major Milestone:
Component: Plugin Version: tested
Keywords: Cc:

Description

Upgrading from 3966 to 4021 today, I start JOSM and:

java.lang.ArrayIndexOutOfBoundsException: 1

at org.openstreetmap.josm.plugins.PluginListParser.parse(PluginListParser.java:99)
at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.processLocalPluginInformationFile(ReadLocalPluginInformationTask.java:177)
at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanSiteCacheFiles(ReadLocalPluginInformationTask.java:96)
at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanLocalPluginRepository(ReadLocalPluginInformationTask.java:164)
at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.realRun(ReadLocalPluginInformationTask.java:223)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:679)

At the first run after the upgrade, it asked to update plugins, and failed. Now, when going to the plugin tab, and clicking "Download list", it fails as well, with a similar OutOfBounds exception like above.

I'm marking it as major, because it broke *all* the plugins I had installed.

Thank you,
David

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by dpaleino

I must say, moving .josm out of the way "solves" the message at startup, but the "Download plugin list" shows the same message. I suspect something is wrong when parsing https://josm.openstreetmap.de/plugin , but everything seems fine to me. Also, there are no differences in org.openstreetmap.josm.plugins.* from 3966 to 4021, so I'm really out of ideas.

Thank you.

comment:2 Changed 11 years ago by dpaleino

Resolution: invalid
Status: newclosed

Whoops.

I was right, the problem was in parsing of https://josm.openstreetmap.de/plugin . However, I had my VPN active, which garbled that file during download (my proxy believed it was spam, or the like). Shutting the VPN down, and re-downloading the plugins list, fixed everything.

Marking the bug as invalid. However, it would be best to give a meaningful error message when the pluginsfile is not readable/parsable (~/.josm/plugins/site-josm.openstreetmap.de-_plugin.txt).

David

comment:3 Changed 11 years ago by stoecker

In [4024/josm]:

see #6214 - better errormessage

comment:4 Changed 10 years ago by stoecker

Ticket #5655 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.