Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6213 closed defect (fixed)

Licence-status per user not correct

Reported by: brogo Owned by: rickmastfan67
Priority: critical Milestone:
Component: Core Version:
Keywords: Cc:

Description

User itschytoo (ID 36292) has accepted the new CT [1], but JOSM shows, that he has not accepted, e.g. for way 24235801 [2].

[1] http://planet.openstreetmap.org/users_agreed/users_agreed.txt

[2] http://www.openstreetmap.org/browse/way/24235801

Attachments (1)

JOSM.7z (37.0 KB) - added by rickmastfan67 10 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 10 years ago by bastiK

IIRC, it is cached for 1 h. You can also remove the mirror_http___planet.openstreetmap.org_users_agreed_users_agreed.txt file from your preferences if you are of the impatient kind.

Last edited 10 years ago by bastiK (previous) (diff)

comment:2 Changed 10 years ago by bastiK

Resolution: worksforme
Status: newclosed

comment:3 in reply to:  1 Changed 10 years ago by brogo

Replying to bastiK:

IIRC, it is cached for 1 h. You can also remove the mirror_http___planet.openstreetmap.org_users_agreed_users_agreed.txt file from your preferences if you are of the impatient kind.

It didn't worked. The mirror-file was dated 14.01.11. Only manually deleting this file brings the correct result.

There was also a recent users_agreed.txt.tmp-file in this directory. But it seems that JOSM gets the information from the old .txt-file.

comment:4 Changed 10 years ago by bastiK

Resolution: worksforme
Status: closedreopened

comment:5 Changed 10 years ago by stoecker

In [4025/josm]:

see #6213 - improve error handling

comment:6 Changed 10 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

In [4026/josm]:

fix #6213 - license info wrong

comment:7 Changed 10 years ago by rickmastfan67

Resolution: fixed
Status: closedreopened

There is still a problem here. I was having the same problem that brogo mentioned in comment:3. Except my problem was worse.

My "mirror_http_planet.openstreetmap.org_users_agreed_users_agreed.txt" file was dated back from January 6th! While the "tmp" file for the users agreed was up-to-date, it wasn't being read by JOSM. I had to manually delete the old "agree" and "disagree" files to get them to update and give me the correct data in JOSM. There's got to be a way to get the main txt file to update more often. That or make JOSM read the "tmp" file all the time if it's more current.

And if other people are having this problem as well, it could cause a lot of trouble.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-05-07 01:31:40
Last Changed Author: framm
Revision: 4076
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-05-06 23:18:24 +0200 (Fri, 06 May 2011)
Last Changed Rev: 4076

Identification: JOSM/1.5 (4076 en)
Memory Usage: 125 MB / 3640 MB (66 MB allocated, but free)
Java version: 1.6.0_25, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

comment:8 Changed 10 years ago by stoecker

Owner: changed from team to brogo
Status: reopenedneedinfo

I need a reproducible way to get such an old file or we can't fix this. Code looks good to me and there should be no blocking which prevents updating the files.

comment:9 Changed 10 years ago by stoecker

Owner: changed from brogo to rickmastfan67

comment:10 in reply to:  8 Changed 10 years ago by rickmastfan67

Replying to stoecker:

I need a reproducible way to get such an old file or we can't fix this. Code looks good to me and there should be no blocking which prevents updating the files.

What OS are you running? This might be a "Windows" only problem if it isn't happening in Linux.

I'm personally running Windows 7 x64 here and this is a problem. The files for this are stored in the following place: "C:\Users\<User Name>\AppData\Roaming\JOSM".

I'm going to attach the files that deal with the Licence status that are in that folder. When you download the 7z file that has them in them, you'll see that "mirror_http_planet.openstreetmap.org_users_agreed_users_agreed.txt" has a "Date Modified" of Janurary 6th, 2011. That file keeps preventing the same file with the *.tmp ending from giving the proper info inside of JOSM.

For instance, it will not say that I have agreed with the Licence when I have already because I agreed after the "Date Modified" date of the default agreed file. Not even hitting the "Load CT" button will get JOSM to show that I have. The only way to force JOSM to show that I have agreed it to delete the Licence files and let JOSM download a completely new set.

Anyways, as I've mentioned above, I've attached the old 01/06/11 agreed file as well as the disagree file + the 2 *.tmp files. This way you'll be able to duplicate it if you can test it on a Windows 7 system.

Also, here's a way that I'm the last person to edit (at least at this moment) so you can test this with the attached files: http://www.openstreetmap.org/browse/way/102526848

Changed 10 years ago by rickmastfan67

Attachment: JOSM.7z added

comment:11 Changed 10 years ago by stoecker

Please attach your config as well (strip username/password), as it contains the relevant mirror information files.

Very likely this is a Windows problem, but Windows should prevent opening/overwriting files only when they are used and JOSM should make sure this file is closed always after reading.

comment:12 in reply to:  11 Changed 10 years ago by rickmastfan67

Replying to stoecker:

Please attach your config as well (strip username/password), as it contains the relevant mirror information files.

Are you talking about the "preferences" file in "C:\Users\<User Name>\AppData\Roaming\JOSM", correct?

If so, the lines I need to delete are "oauth.access-token.key" and "oauth.access-token.secret", correct? That and tweak any lines that mention my "user id" for windows?

Also, do you need me to attach "preferences_backup" as well, or is just the main "preferences" file enough?

comment:13 Changed 10 years ago by stoecker

Only the main file.

comment:14 Changed 10 years ago by rickmastfan67

Alright, I'll attach it in a second. But I'd still prefer that you'd delete it once you have it downloaded as only you head JOSM programers need it to try to fix this bug. ;)

Anyways, I striped out my oauth info as well as anything that mentioned personal folders (non "AppData" folders) and changed lines that referenced the JOSM data folder to include "<User Name>" instead of my Windows account name for safety reasons. ;)

comment:15 Changed 10 years ago by stoecker

Ok. Deleted file. Well the prefs file says that the files are from date which is of ".tmp" file. Hmpf, seems I need to setup JOSM on an Win7 system myself to test this. I hate windows!

comment:16 Changed 10 years ago by stoecker

In [4145/josm]:

see #6213 - do more file closes hopefully fixing some update problems under windows

comment:17 Changed 10 years ago by stoecker

Last try fixing without Windows: Could you try r4145? The tmp file should vanish and the normal file be up-to-date. If not, you should get at least a message in command line, that the file could not be renamed.

comment:18 in reply to:  17 Changed 10 years ago by rickmastfan67

Replying to stoecker:

Last try fixing without Windows: Could you try r4145? The tmp file should vanish and the normal file be up-to-date. If not, you should get at least a message in command line, that the file could not be renamed.

I'll try it once it gets built later today and let you know. ;)

comment:19 Changed 10 years ago by rickmastfan67

Alright, I got a message to pop up in the CL when I ran r4152. Here's what it is:

Failed to rename file C:\Users\<User Name>\AppData\Roaming\JOSM\mirror_http___planet.openstreetmap.org_users_agreed_users_agreed.txt.tmp to C:\Users\<User Name>\AppData\Roaming\JOSM\mirror_http___planet.openstreetmap.org_users_agreed_users_agreed.txt.
Failed to rename file C:\Users\<User Name>\AppData\Roaming\JOSM\mirror_http___planet.openstreetmap.org_users_agreed_users_disagreed.txt.tmp to C:\Users\<User Name>\AppData\Roaming\JOSM\mirror_http___planet.openstreetmap.org_users_agreed_users_disagreed.txt.

So, for some reason, JOSM can't rename the old text file in Windows 7 x64.

comment:20 Changed 10 years ago by stoecker

Resolution: fixed
Status: needinfoclosed

In [4153/josm]:

fix #6213 - input stream mirror update failed on Windows

comment:21 in reply to:  20 Changed 10 years ago by rickmastfan67

Replying to stoecker:

In [4153/josm]:

fix #6213 - input stream mirror update failed on Windows

That fix did the trick. The files finally updated correctly. :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain rickmastfan67.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.