Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#5805 closed defect (fixed)

link to a file with extension .3gpp does not open that file

Reported by: mtb Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: .3ggp link 'voice recording' 'OSM tracker for Android' Cc:

Description (last modified by Don-vip)

When I open a .gpx file created by 'OSM tracker for Android' and then in JOSM click on a waypoint with a link to a sound file (extension .3gpp ), the assigned Windows media player does not open. Thus, I cannot listen to my voice recording directly from JOSM (from Windows explorer, it does work).

I use Windows XP, latest JOSM version 3751, Java 1.6.0_22

I tried old JOSM versions from http://josm.openstreetmap.de/download/ and found out the following:

  • until and including version 3522 from Sep 11th, it still works fine (i.e. media player opens)
  • but as of the next version available on http://josm.openstreetmap.de/download/ (that's version 3525 from Sep 14th), nothing happens at a click on the waypoint with a link (i.e. error occurs).

In the .gpx file, the waypoints are stored like in the following example:

<wpt lat="49.41648244857788" lon="8.417962789535522">

<ele>140.0</ele>
<time>2010-12-30T15:29:01Z</time>
<name><![CDATA[Sprachaufnahme]]></name>
<link href="2010-12-30_16-29-25.3gpp">

<text>2010-12-30_16-29-25.3gpp</text>

</link>
<sat>9</sat>

</wpt>

Thus, my request is: would you please enable direct link to the .3gpp sound files as it used to be until JOSM 3522?

Thanks and regards,
Hans-Peter
(user 'mtb' in OSM)

Attachments (2)

2011-11-05_10-43-35.gpx (171.3 KB) - added by janetworkx@… 8 years ago.
GPX file created by osmtracker for android (version: latest in android market)
2011-11-05_10-48-23.3gpp (4.1 KB) - added by janetworkx@… 8 years ago.
3gpp File with recorded voice

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by anonymous

Exactly the same behavior is observed in r3751 on Windows 7. The 3gpp file works when double clicked in explorer, but fails to be played from josm, with the following stack trace:

java.io.IOException: Failed to open file:/C:/Users/par.TIDAX-AB/Desktop/osm/2011-01-10_12-46-41/2011-01-10_12-59-23.3gpp. Error message: Unspecified error

at sun.awt.windows.WDesktopPeer.ShellExecute(Unknown Source)
at sun.awt.windows.WDesktopPeer.browse(Unknown Source)
at java.awt.Desktop.browse(Unknown Source)
at org.openstreetmap.josm.tools.OpenBrowser.displayUrl(OpenBrowser.java:43)
at org.openstreetmap.josm.tools.OpenBrowser.displayUrl(OpenBrowser.java:64)
at org.openstreetmap.josm.gui.layer.markerlayer.WebMarker.actionPerformed(WebMarker.java:39)
at org.openstreetmap.josm.gui.layer.markerlayer.MarkerLayer$1$1.mouseReleased(MarkerLayer.java:132)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

comment:2 Changed 8 years ago by janetworkx@…

Also here under debian:sid, josm:4574 the .3gpp soundfiles do not open.

java.io.IOException: Failed to show URI:file:/tmp/2011-11-05_10-43-35/2011-11-05_10-52-15.3gpp

at sun.awt.X11.XDesktopPeer.launch(XDesktopPeer.java:75)
at sun.awt.X11.XDesktopPeer.browse(XDesktopPeer.java:64)
at java.awt.Desktop.browse(Desktop.java:368)
at org.openstreetmap.josm.tools.OpenBrowser.displayUrl(OpenBrowser.java:43)
at org.openstreetmap.josm.tools.OpenBrowser.displayUrl(OpenBrowser.java:64)
at org.openstreetmap.josm.gui.layer.markerlayer.WebMarker.actionPerformed(WebMarker.java:31)
at org.openstreetmap.josm.gui.layer.markerlayer.MarkerLayer$1$1.mouseReleased(MarkerLayer.java:116)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:273)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
at java.awt.Component.processMouseEvent(Component.java:6288)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:6053)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4651)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4481)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4481)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:643)
at java.awt.EventQueue.access$000(EventQueue.java:84)
at java.awt.EventQueue$1.run(EventQueue.java:602)
at java.awt.EventQueue$1.run(EventQueue.java:600)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
at java.awt.EventQueue$2.run(EventQueue.java:616)
at java.awt.EventQueue$2.run(EventQueue.java:614)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:613)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

comment:3 Changed 8 years ago by Don-vip

Description: modified (diff)

Can you attach a sample file please ?

Changed 8 years ago by janetworkx@…

Attachment: 2011-11-05_10-43-35.gpx added

GPX file created by osmtracker for android (version: latest in android market)

comment:4 Changed 8 years ago by Don-vip

I was talking about a .3gpp file :)

Changed 8 years ago by janetworkx@…

Attachment: 2011-11-05_10-48-23.3gpp added

3gpp File with recorded voice

comment:5 Changed 8 years ago by Don-vip

Well, strange, it works for me (Windows 7 x64, jre 1.6.0.29).

comment:6 in reply to:  5 Changed 8 years ago by janetworkx@…

Replying to Don-vip:

Well, strange, it works for me (Windows 7 x64, jre 1.6.0.29).

When I take the URI from my former example (file:/tmp/2011-11-05_10-43-35/2011-11-05_10-52-15.3gpp) and enter it into the KDE Dolphin File Explorer, it also opens the designated media player app, and plays the 3gpp file. I've not enough knowledge about Java. Maybe a solution is hidden behind the reported trace?

Cheers Andreas

comment:7 Changed 8 years ago by Don-vip

Java Desktop API does not work under KDE: http://bugs.sun.com/view_bug.do?bug_id=6486393

I try a workaround.

comment:8 Changed 8 years ago by Don-vip

In [4578/josm]:

see #5805 - Java Desktop API Fallback on unsupported-but-said-supported platforms such as KDE

comment:9 Changed 8 years ago by Don-vip

Let me know tomorrow if it changes anything or not.

comment:10 in reply to:  9 Changed 8 years ago by anonymous

Replying to Don-vip:

Let me know tomorrow if it changes anything or not.

Thx a lot - now it works fine! :-)

Cheers Andreas

comment:11 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

comment:12 Changed 6 years ago by anonymous

Resolution: fixed
Status: closedreopened

Hi,

I think there has been a regression here. At least on my JOSM (latest stable) on Win 7 I can not load 3gp or 3gpp. Only wav is supported atm. Can you confirm this?
Is it possible to re-introduce 3gp audio support?

Thank you for a great program!

comment:13 Changed 6 years ago by anonymous

I can confirm that on Win7 64bit I can only open and associate wav files with gpx tracks. I would like 3gp support, too, since Osmand on my Android phone only saves audio in this format.

comment:14 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

This is not a regression. JOSM never had a real support of 3GP format and never will until Java itself supports it.
This ticket was about 3gpp files references directly from the GPX file (see example attachments):

        <wpt lat="50.76171407941729" lon="10.155265191569924">
                <ele>354.70001220703125</ele>
                <time>2011-11-05T09:44:17Z</time>
                <name><![CDATA[Sprachaufnahme]]></name>
                <link href="2011-11-05_10-44-14.3gpp">
                        <text>2011-11-05_10-44-14.3gpp</text>
                </link>
                <sat>6</sat>
        </wpt>

These files are open with the platform's associated audio player when markers are clicked, it still works with last version, and there is nothing more we plan to do for 3GP support.

comment:15 Changed 6 years ago by anonymous

Ah, sorry.
There seems to be something wrong in the GPX from OSMand:

<wpt lat="(...)" lon="(...)">
    <name>0Dr8PM9d---1.3gp</name>
    <time>(...)</time>
</wpt>

There is no <link> at all in my gpx.
All media and image files are included in a <name> tag only.

And still, I can show the jpgs at their right location in JOSM after I right click the gpx layer and select "import images". The images need to be correlated, but that's easy, since there is no offset (images are from the phone that recorded the track). The pictures do not have gps coordinates in the exif (which is a bit strange), but I believe the name is a kind of coded coordinates (there was something on a wiki page about this, can't find it now). After this preparation, I can click the images and see them in JOSM.

The audio (3gp) and video (mp4) files are saved with a file date and a geocoded name.
Could this information be used to correlate these files with the track in JOSM?

Or - much simpler - could a <wpt> with a <name> that looks like a filename just automatically correlate with these files?

Thanks again for a really cool tool!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.