Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5559 closed defect (fixed)

josm still does not use or even delete saved osm-states

Reported by: wambacher Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: autosave Cc:

Description

hi, still the old problem - for me -

i can only delete the autosave-directory to get rid of that stuff.
some older release "fixed" that bug, but i don't see any changes.
i'm using version 3609 but i've seen NO version dealing with that problem.
regards
walter

Attachments (5)

snap2.png (16.7 KB) - added by anonymous 11 years ago.
snap1.png (25.7 KB) - added by anonymous 11 years ago.
discard_strace.log.bz2 (937.9 KB) - added by wambacher 11 years ago.
strace discarding recovery-files
recover_strace.log.bz2 (978.0 KB) - added by wambacher 11 years ago.
trying to recover edits.
5548.tar.bz2 (589.8 KB) - added by frief 11 years ago.
debug output for ticket #5548 with josm 3678

Change History (17)

Changed 11 years ago by anonymous

Attachment: snap2.png added

Changed 11 years ago by anonymous

Attachment: snap1.png added

comment:1 Changed 11 years ago by peter_ille

found that #5548 is the same problem but less infos.

comment:2 Changed 11 years ago by jttt

Next time this happen, can you please run it in strace? The command would be:

strace -f -o strace.log java -jar josm-latest.jar

Start josm, click on Discard button, close josm and attach strace.log to this ticket.

Changed 11 years ago by wambacher

Attachment: discard_strace.log.bz2 added

strace discarding recovery-files

Changed 11 years ago by wambacher

Attachment: recover_strace.log.bz2 added

trying to recover edits.

comment:3 in reply to:  2 Changed 11 years ago by anonymous

Replying to jttt:

Next time this happen, can you please run it in strace? The command would be:

strace -f -o strace.log java -jar josm-latest.jar

Start josm, click on Discard button, close josm and attach strace.log to this ticket.

done.

regards
walter

comment:4 Changed 11 years ago by bastiK

Added debug output in [3675], could you please run again, click on "discard" (3rd button, just to avoid misunderstanding) and report the console output?

(I looked at the strace. There should be 2 attempts to read/list the autosave folder: one on start and one after you clicked the discard button. But only the first is present, which leads me to believe that for some reason, some code isn't executed at all.)

comment:5 Changed 11 years ago by bastiK

Ticket #5548 has been marked as a duplicate of this ticket.

comment:6 Changed 11 years ago by bastiK

Ticket #5499 has been marked as a duplicate of this ticket.

Changed 11 years ago by frief

Attachment: 5548.tar.bz2 added

debug output for ticket #5548 with josm 3678

comment:7 Changed 11 years ago by frief

continuing from ticket #5548

Could you please rerun with r3675 and report
debugging output to ticket #5559?

not fixed for me with r3678.

I'm attaching the strace output mentioned above,
console output and the output of
josm/help/show_status_report.txt

(just start, then discard)

Greetings,
Frieder

comment:8 Changed 11 years ago by bastiK

In [3679/josm]:

see #5559 - ExtendedDialog.showDialog() blocks when called in main thread, so move gui stuff to edt. This problem is highly system dependent (i could never reproduce it myself, but seems to be quite common)

comment:9 Changed 11 years ago by bastiK

This should solve the problem, please confirm!

comment:10 Changed 11 years ago by frief

Fixes the problem for me, thanks!)

comment:11 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

comment:12 Changed 11 years ago by bastiK

Ticket #5656 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.