Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5558 closed defect (fixed)

crash when loading specific waypoint file

Reported by: stone02@… Owned by: OliverW
Priority: normal Milestone:
Component: Plugin elevationprofile Version: latest
Keywords: crash Cc:

Description

Hi, as mentioned above I've problems loading two of my waypoint files (marked waypoints only). They were created and loaded from my Gramin Oregon 400t as all my older gpx files (except the older files work and don't crash JOSM).

Additinally I want to mention that I haven't made any update to my Oregon device since this error occurs. I've attached a working file and two non-working files.

Best regards

Attachments (3)

Alte Hochstraße-Pistlwies.gpx (5.5 KB) - added by stone02@… 11 years ago.
working gpx file
OSL-Wegpunkte-12-10-10.gpx (6.1 KB) - added by stone02@… 11 years ago.
non-working (JOSM hangs)
threaddump.txt (11.5 KB) - added by stone02@… 11 years ago.
JOSM thread dump

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by stone02@…

working gpx file

Changed 11 years ago by stone02@…

Attachment: OSL-Wegpunkte-12-10-10.gpx added

non-working (JOSM hangs)

comment:1 Changed 11 years ago by anonymous

I should clarify that JOSM doesn't crash but hangs and I have to kill the process.

comment:2 Changed 11 years ago by jttt

I've tried to load your files and it works fine. Does it always hang or was it a one-time problem?

If it happens again, please attach thread dump. See http://www.crazysquirrel.com/computing/java/basics/java-thread-dump.jspx

comment:3 Changed 11 years ago by stone02@…

It always hangs (reproducible). I've attached the requested thread dump.

Changed 11 years ago by stone02@…

Attachment: threaddump.txt added

JOSM thread dump

comment:4 Changed 11 years ago by jttt

Component: CorePlugin

The hang is caused by ElevationProfile plugin (which I can't fix because it's not is osm svn)

comment:5 Changed 11 years ago by anonymous

Owner: changed from team to OliverW

comment:6 Changed 11 years ago by stoecker

Component: PluginPlugin elevationprofile

comment:7 Changed 11 years ago by OliverW

Resolution: fixed
Status: newclosed

comment:8 Changed 11 years ago by OliverW

Problem fixed in release 23977, please update your ElevationProfile plugin.

comment:9 Changed 11 years ago by OliverW

Ticket #5598 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.