Modify

Opened 11 years ago

Closed 11 years ago

#5598 closed defect (fixed)

Elevationprofile plugin crashes after canceling download of gpx points - and blocks JOSM

Reported by: Cobra Owned by: OliverW
Priority: critical Milestone:
Component: Plugin elevationprofile Version: latest
Keywords: Cc:

Description

I tried to load new data without success due to broken internet access.
After the gpx download stopped, this popped up. And kept popping up again and again and again and again.... even though I selected "disable plugin" to get rid of this. "Do nothing" just brings the same thing up again. Only killing josm helps to stop that.

Because of the latter fact I rate this bug "critical".

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-11-01 02:31:23
Last Changed Author: bastiK
Revision: 3647
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-10-31 13:12:59 +0100 (Sun, 31 Oct 2010)
Last Changed Rev: 3647

Identification: JOSM/1.5 (3647 en)
Memory Usage: 370 MB / 531 MB (82 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: ElevationProfile (23758)
Plugin: PicLayer (22549)
Plugin: alignways (23560)
Plugin: colorscheme (21563)
Plugin: measurement (22547)
Plugin: openstreetbugs (22723)
Plugin: openvisible (21706)
Plugin: remotecontrol (22734)
Plugin: reverter (23278)
Plugin: validator (23192)
Plugin: wmsplugin (23454)

java.lang.RuntimeException: WPT must not be null, profile ElevationProfileBase [start=Thu Jan 01 01:00:00 CET 1970, end=Thu Oct 21 10:31:58 CEST 2010, minHeight=2147483647, maxHeight=-2147483648]
	at org.openstreetmap.josm.plugins.elevation.gui.DefaultElevationProfileRenderer.renderWayPoint(DefaultElevationProfileRenderer.java:139)
	at org.openstreetmap.josm.plugins.elevation.gui.ElevationProfileLayer.paint(ElevationProfileLayer.java:215)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:516)
	at javax.swing.JComponent.paintChildren(JComponent.java:862)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1030)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintChildren(JComponent.java:862)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintChildren(JComponent.java:862)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintChildren(JComponent.java:862)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintChildren(JComponent.java:862)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JLayeredPane.paint(JLayeredPane.java:567)
	at javax.swing.JComponent.paintChildren(JComponent.java:862)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5131)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1479)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1410)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:294)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1224)
	at javax.swing.JComponent.paint(JComponent.java:1015)
	at java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:21)
	at sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:60)
	at sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:97)
	at java.awt.Container.paint(Container.java:1780)
	at java.awt.Window.paint(Window.java:3375)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:713)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:693)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:125)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by OliverW

There has been a related error (#5558) which has already been fixed.

You are using the (buggy) version 23758, so please update to the current one (23977) und try again.

Last edited 11 years ago by OliverW (previous) (diff)

comment:2 Changed 11 years ago by OliverW

Resolution: duplicate
Status: newclosed

comment:3 Changed 11 years ago by OliverW

Closed as duplicate of #5558.

comment:4 Changed 11 years ago by OliverW

Resolution: duplicate
Status: closedreopened

comment:5 Changed 11 years ago by OliverW

Bug has been fixed, please update to version 24034.

Please provide the GPX file which caused the error in future - thanks.

comment:6 Changed 11 years ago by OliverW

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.