Modify

Opened 9 years ago

Closed 4 years ago

Last modified 4 years ago

#5309 closed defect (fixed)

too many files in tile cache

Reported by: ieskok Owned by: team
Priority: major Milestone: 15.04
Component: Core imagery Version: tested
Keywords: cache Cc: naoliv

Description (last modified by Don-vip)

Slippy map browser creates cache in temp directory, but after time there is thousands of files in that one dir. JOSM shows error:
Failed to save tile content: .... (The directory or file cannot be created)
Failed to sa ETag...
Windows cannot handle so many files in one dir. Maybe there should be nested directories?

Attachments (0)

Change History (26)

comment:1 Changed 7 years ago by Don-vip

Ticket #8371 has been marked as a duplicate of this ticket.

comment:2 Changed 6 years ago by Don-vip

Component: CoreCore imagery
Description: modified (diff)

comment:3 Changed 6 years ago by jezevec

For now, I have 100 000 files in ..\JOSM\cache\wms\1 and it's extremly slow. Is possible add something like auto remove cache files?

Second, there is no dir setting - so if I want cache other then user profile ...

comment:4 in reply to:  3 Changed 6 years ago by AlfonZ

Replying to jezevec:

For now, I have 100 000 files in ..\JOSM\cache\wms\1 and it's extremly slow. Is possible add something like auto remove cache files?

Auto cleaning has been suggested in #7762 as well.

Second, there is no dir setting - so if I want cache other then user profile ...

#6248 suggests using advanced preference imagery.wms-cache.path.

comment:5 Changed 6 years ago by Don-vip

Ticket #7762 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by Don-vip

Milestone: 14.05
Priority: minormajor

JDK7 NIO2 could be helpful to improve our tile cache.

comment:7 Changed 6 years ago by naoliv

Cc: naoliv added

What about using something like the ​ImageryCache plugin? ("This experimental plugin allows JOSM to store tile cache in database files, not in huge cache directories")

comment:8 Changed 6 years ago by skyper

I would prefer to use an even more general solution and have the cache in proper system dirs and customizable.
The advantage would be that even other software could use the same cache

For Linux Desktops the proper dir would be probably under $HOME/.cache/ theses days.

Think there is already one ticket about original reported on the Debian Bug Tracker.

comment:10 in reply to:  9 Changed 6 years ago by skyper

Replying to naoliv:

At http://bugs.debian.org/528320

Which is #4904 on our side.

comment:11 Changed 6 years ago by skyper

Keywords: cache added

ATM the major reason for filling the disk on my part is #9263

comment:12 Changed 5 years ago by Don-vip

Milestone: 14.0514.06

Move imagery cache-related tickets to next milestone (too risky now for this release)

comment:13 Changed 5 years ago by Don-vip

Milestone: 14.0614.07

Move all tickets for which no work has been done yet to next milestone

comment:14 Changed 5 years ago by Don-vip

Milestone: 14.0714.08

Move some tickets to next milestone

comment:15 Changed 5 years ago by Don-vip

Milestone: 14.0814.09

move imagery cache tickets to next milestone

comment:16 Changed 5 years ago by Don-vip

Milestone: 14.0914.10

Move complicated/risky tickets to next milestone.

comment:17 Changed 5 years ago by Don-vip

Milestone: 14.1014.11

Not enough time/resources for these tickets this month.

comment:18 Changed 5 years ago by Don-vip

Milestone: 14.1114.12

comment:19 Changed 5 years ago by bastiK

In [o30854] - see ​#josm5309 - rework cache directory structure so you don't have too many files in in one directory
New cache is implemented in TMSFileCacheTileLoader. Old cache in OsmFileCacheTileLoader? should work
as before.

comment:20 Changed 5 years ago by bastiK

In 7823/josm:

see #5309 - too many files in tile cache (see [o30854])
Set Einstein pref tms.newcache=true to test the new cache, it is not yet activated by default.

comment:21 Changed 5 years ago by bastiK

[o30854] and [7823] refer to the TMS cache, while this ticket seems to be more about WMS. see also #9813.

comment:22 Changed 5 years ago by Don-vip

Milestone: 14.1215.01

finish all cache-related tickets next month

comment:23 Changed 5 years ago by stoecker

Milestone: 15.0115.02

Again delayed.

comment:24 Changed 5 years ago by Don-vip

Milestone: 15.02

comment:25 in reply to:  20 Changed 4 years ago by wiktorn

Resolution: fixed
Status: newclosed

Fixed in [8168] and later patches

comment:26 Changed 4 years ago by Don-vip

Milestone: 15.04

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.