Modify

Opened 12 years ago

Closed 7 years ago

Last modified 7 years ago

#6248 closed enhancement (fixed)

WMS tile cache location in imagery preferences

Reported by: rickmastfan67 Owned by: team
Priority: normal Milestone: 15.08
Component: Core imagery Version:
Keywords: tile cache preferences Cc:

Description

It is possible that we as end users can select the folder we want to have the WMS download images to? We already have that ability with TMS images. It would be greatly appreciated since I want to be able to delete all the stored images at one single time when the folders get too big since the "Flush Tile Cache" doesn't seem to work anymore (see #6109).

Attachments (0)

Change History (30)

comment:1 Changed 9 years ago by Don-vip

Component: CoreCore imagery
Keywords: tile cache preferences added
Summary: Imagery preferences for WMS enhancementWMS tile cache location in imagery preferences

comment:2 Changed 9 years ago by skyper

There is also a bug report on Debian bug tracker complaining about not using system defaults at least for imageries.

comment:3 Changed 9 years ago by Don-vip

And it leads to #4904 on our side :)

comment:4 Changed 9 years ago by rickmastfan67

Ticket #8899 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by bastiK

You can change the WMS cache folder by setting the advanced preference value for imagery.wms-cache.path.

Maybe a GUI textbox would be nice.

comment:6 Changed 9 years ago by Don-vip

From #9707 (WMS cache should not be stored in AppData/Roaming on Windows machine):

If machine is part of Windows domain then folder AppData/Roaming is stored on file server and copied every time user log on. Storing big amount of data causes login delay, unnecessary LAN use, etc. /Roaming is for application setting. Big, temporary data should be stored in AppData/Local. ​https://en.wikipedia.org/wiki/Roaming_user_profile#Third-party_companies_don.27t_use_it_correctly

comment:7 Changed 9 years ago by Don-vip

Milestone: 14.05

comment:8 Changed 9 years ago by Don-vip

Milestone: 14.0514.06

Move imagery cache-related tickets to next milestone (too risky now for this release)

comment:9 Changed 8 years ago by Don-vip

Milestone: 14.0614.07

Move all tickets for which no work has been done yet to next milestone

comment:10 Changed 8 years ago by Don-vip

Milestone: 14.0714.08

Move some tickets to next milestone

comment:11 Changed 8 years ago by Don-vip

Milestone: 14.0814.09

move imagery cache tickets to next milestone

comment:12 Changed 8 years ago by Don-vip

Milestone: 14.0914.10

Move complicated/risky tickets to next milestone.

comment:13 Changed 8 years ago by Don-vip

Milestone: 14.1014.11

Not enough time/resources for these tickets this month.

comment:14 Changed 8 years ago by Don-vip

Milestone: 14.1114.12

comment:15 Changed 8 years ago by Don-vip

In 7829/josm:

see #6248, #10026 - use recommended cache directories on Windows and OSX. Linux behaviour is unchanged

comment:16 Changed 8 years ago by bastiK

Does this work in Win XP?

comment:17 Changed 8 years ago by Don-vip

It should, this variable has been introduced with windows 2000

comment:18 Changed 8 years ago by bastiK

In 7832/josm:

see #6248 - fix path for Win XP

comment:19 Changed 8 years ago by bastiK

In 7833/josm:

see #6248 - typo

comment:20 Changed 8 years ago by bastiK

I tried on a Win XP box - System.getenv("LOCALAPPDATA") returns null.

comment:21 Changed 8 years ago by Don-vip

Right, looks like http://www.microsoft.com/security/portal/mmpc/shared/variables.aspx is wrong and this variable has only been added with Windows Vista.

comment:22 Changed 8 years ago by bastiK

I think it is available somehow, but not as environment variable.

comment:23 Changed 8 years ago by Don-vip

I honestly don't care about Windows XP :)

comment:24 Changed 8 years ago by bastiK

According to JOSM logs, Windows XP is more popular than iOS. Outside of OSM it is also more popular than Linux, of course. Nevertheless, there is nothing we can / should do here.

comment:25 Changed 8 years ago by Don-vip

Milestone: 14.1215.01

finish all cache-related tickets next month

comment:26 Changed 8 years ago by stoecker

Milestone: 15.0115.02

Again delayed.

comment:27 Changed 8 years ago by Don-vip

Milestone: 15.02

comment:28 Changed 7 years ago by wiktorn

Resolution: fixed
Status: newclosed

In josm-latest there is only 2 files for WMS cache, in the same folder as for TMS.

For TMS you have files:
TMS.data
TMS.key

And for WMS you have files:
WMS.data
WMS.key

Flush Tile Cache is also working right now, so I close the ticket.

comment:29 Changed 7 years ago by Don-vip

Milestone: 15.07

comment:30 Changed 7 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.