Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#5094 closed defect (fixed)

crash on loading an area or editing a relation

Reported by: vsandre Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc: framm

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-06-02 01:31:37
Last Changed Author: bastiK
Revision: 3293
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-06-01 21:51:48 +0200 (Tue, 01 Jun 2010)
Last Changed Rev: 3293

Memory Usage: 216 MB / 910 MB (64 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Dataset consistency test:
No problems found


Plugins: DirectUpload,PicLayer,colorscheme,dataimport,editgpx,measurement,remotecontrol,reverter,slippymap,turnrestrictions,undelete,validator,wmsplugin
Plugin undelete (Version: 21186)
Plugin PicLayer (Version: 20217)
Plugin dataimport (Version: 20431)
Plugin reverter (Version: 21237)
Plugin validator (Version: 21440)
Plugin slippymap (Version: 21136)
Plugin measurement (Version: 21307)
Plugin turnrestrictions (Version: 21186)
Plugin colorscheme (Version: 19426)
Plugin editgpx (Version: 21474)
Plugin wmsplugin (Version: 21235)
Plugin remotecontrol (Version: 21433)
Plugin DirectUpload (Version: 20881)

java.lang.NullPointerException
	at org.openstreetmap.josm.tools.I18n.gettext(I18n.java:73)
	at org.openstreetmap.josm.tools.I18n.tr(I18n.java:38)
	at org.openstreetmap.josm.gui.DefaultNameFormatter.format(DefaultNameFormatter.java:171)
	at org.openstreetmap.josm.data.osm.Relation.getDisplayName(Relation.java:290)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel$1.compare(RelationListDialog.java:583)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel$1.compare(RelationListDialog.java:579)
	at java.util.Arrays.mergeSort(Unknown Source)
	at java.util.Arrays.mergeSort(Unknown Source)
	at java.util.Arrays.mergeSort(Unknown Source)
	at java.util.Arrays.sort(Unknown Source)
	at java.util.Collections.sort(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.sort(RelationListDialog.java:577)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.setRelations(RelationListDialog.java:607)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.initFromLayer(RelationListDialog.java:180)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.dataChanged(RelationListDialog.java:840)
	at org.openstreetmap.josm.data.osm.event.DataChangedEvent.fire(DataChangedEvent.java:26)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.fireEvents(DatasetEventManager.java:109)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.access$200(DatasetEventManager.java:27)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager$1.run(DatasetEventManager.java:139)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

the same after editing an relation (add a member)

java.lang.NullPointerException
	at org.openstreetmap.josm.tools.I18n.gettext(I18n.java:73)
	at org.openstreetmap.josm.tools.I18n.tr(I18n.java:38)
	at org.openstreetmap.josm.gui.DefaultNameFormatter.format(DefaultNameFormatter.java:171)
	at org.openstreetmap.josm.data.osm.Relation.getDisplayName(Relation.java:290)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel$1.compare(RelationListDialog.java:583)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel$1.compare(RelationListDialog.java:579)
	at java.util.Arrays.mergeSort(Unknown Source)
	at java.util.Arrays.mergeSort(Unknown Source)
	at java.util.Arrays.mergeSort(Unknown Source)
	at java.util.Arrays.sort(Unknown Source)
	at java.util.Collections.sort(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.sort(RelationListDialog.java:577)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.relationMembersChanged(RelationListDialog.java:821)
	at org.openstreetmap.josm.data.osm.event.RelationMembersChangedEvent.fire(RelationMembersChangedEvent.java:22)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.fireEvents(DatasetEventManager.java:109)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.access$200(DatasetEventManager.java:27)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager$1.run(DatasetEventManager.java:139)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.Dialog$1.run(Unknown Source)
	at java.awt.Dialog$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Unknown Source)
	at javax.swing.JOptionPane.showOptionDialog(Unknown Source)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler.handleException(BugReportExceptionHandler.java:67)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler.handle(BugReportExceptionHandler.java:41)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at java.awt.EventDispatchThread.handleException(Unknown Source)
	at java.awt.EventDispatchThread.processException(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

cosa_rara_girona.osm (31.1 KB) - added by ivansanchez 13 years ago.
Originally attached to #5116

Download all attachments as: .zip

Change History (13)

comment:1 Changed 13 years ago by vsandre

The relation list dialogue is empty, too.

comment:2 Changed 13 years ago by stoecker

Please add a data file where this happens.

comment:3 Changed 13 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3296]) fixed #5094 - crash on loading an area or editing a relation

comment:4 Changed 13 years ago by vsandre

It occurs if you downloads an area with a public_transport route.

BTW [3296] works.

comment:5 Changed 13 years ago by stoecker

Ticket #5095 has been marked as a duplicate of this ticket.

comment:6 Changed 13 years ago by stoecker

Ticket #5096 has been marked as a duplicate of this ticket.

comment:7 Changed 13 years ago by stoecker

Cc: framm added

@Frederik:

Can you issue a new build (I can't ATM). This seems a serious problem.

comment:8 Changed 13 years ago by stoecker

Ticket #5099 has been marked as a duplicate of this ticket.

comment:9 Changed 13 years ago by stoecker

Ticket #5111 has been marked as a duplicate of this ticket.

comment:10 Changed 13 years ago by stoecker

Ticket #5116 has been marked as a duplicate of this ticket.

Changed 13 years ago by ivansanchez

Attachment: cosa_rara_girona.osm added

Originally attached to #5116

comment:11 Changed 13 years ago by ivansanchez

I just uploaded a sample .osm file which I can reproduce this bug with.

Just load it and select one of the ways that make up the relation.

comment:12 Changed 13 years ago by stoecker

This bug is fixed. You need to update!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.