Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5116 closed defect (duplicate)

Exception when selecting way inside relation

Reported by: ivansanchez Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

This is easier to reproduce than to explain, so:

  • Open the attached .osm file
  • There are two relations in that .osm file. Select any way contained in any of those.
  • Voilà! Error message:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-06-02 01:31:37
Last Changed Author: bastiK
Revision: 3293
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-06-01 21:51:48 +0200 (Tue, 01 Jun 2010)
Last Changed Rev: 3293

Memory Usage: 62 MB / 247 MB (27 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP

Dataset consistency test:
No problems found

Plugins: multipoly,multipoly-convert,openstreetbugs,openvisible,routing,validator,walkingpapers,waydownloader,wayselector,wms-turbo-challenge2,wmsplugin
Plugin walkingpapers (Version: 19487)
Plugin openstreetbugs (Version: 20696)
Plugin wmsplugin (Version: 21235)
Plugin openvisible (Version: 20067)
Plugin wayselector (Version: 21186)
Plugin validator (Version: 21440)
Plugin waydownloader (Version: 19489)
Plugin routing (Version: 19475)
Plugin multipoly-convert (Version: 21186)
Plugin multipoly (Version: 19456)

java.lang.NullPointerException

at org.openstreetmap.josm.tools.I18n.gettext(I18n.java:73)
at org.openstreetmap.josm.tools.I18n.tr(I18n.java:38)
at org.openstreetmap.josm.gui.DefaultNameFormatter.format(DefaultNameFormatter.java:171)
at org.openstreetmap.josm.data.osm.Relation.getDisplayName(Relation.java:290)
at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog$11.getTableCellRendererComponent(PropertiesDialog.java:537)
at javax.swing.JTable.prepareRenderer(Unknown Source)
at javax.swing.plaf.basic.BasicTableUI.paintCell(Unknown Source)
at javax.swing.plaf.basic.BasicTableUI.paintCells(Unknown Source)
at javax.swing.plaf.basic.BasicTableUI.paint(Unknown Source)
at javax.swing.plaf.ComponentUI.update(Unknown Source)
at javax.swing.JComponent.paintComponent(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintToOffscreen(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
at javax.swing.BufferStrategyPaintManager.paint(Unknown Source)
at javax.swing.RepaintManager.paint(Unknown Source)
at javax.swing.JComponent._paintImmediately(Unknown Source)
at javax.swing.JComponent.paintImmediately(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

I don't know if this has anything to do with the name:ca keys, or the fact that the relations are tagged as highways (a byproduct of ogr2osm and some topologically wrong data)

Attachments (1)

cosa_rara_girona.osm (31.1 KB) - added by ivansanchez 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by ivansanchez

Attachment: cosa_rara_girona.osm added

comment:1 Changed 11 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by stoecker

Closed as duplicate of #5094.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.