Modify

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#5093 closed defect (fixed)

translation for open file

Reported by: jezevec Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Seems there are no translation strings for open file dialog.

Strings without translation examples:
Look In, File Name, Files Of Type, Up One Level etc.

In attached img is cs version with some translated filetypes.

Attachments (1)

OpenFile.png (31.7 KB) - added by jezevec 12 years ago.
Open file dialog

Download all attachments as: .zip

Change History (15)

Changed 12 years ago by jezevec

Attachment: OpenFile.png added

Open file dialog

comment:1 Changed 12 years ago by stoecker

Resolution: wontfix
Status: newclosed

This is part of Java. We can't translate this without replacing the dialog completely. I think there is another ticket which had a possible suggestion to do string-injection into the dialog, but I can't find it.

comment:2 Changed 12 years ago by bastiK

Resolution: wontfix
Status: closedreopened

comment:3 Changed 12 years ago by bastiK

Ticket #4636 has been marked as a duplicate of this ticket.

comment:4 Changed 12 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

(In [3294]) fixed #5093 - translation for open file

comment:5 Changed 12 years ago by stoecker

Resolution: fixed
Status: closedreopened

You need to extract the messages and save them in "specialmessages.java" in i18n dir, or we wont have translations for them!

comment:6 Changed 12 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

I'm aware of that, but cannot do it at the same time :)

comment:7 Changed 12 years ago by stoecker

No multitasking?

comment:8 Changed 12 years ago by bastiK

my computer yes, but for my brain i missed the latest update

comment:9 Changed 11 years ago by bastiK

Resolution: fixed
Status: closedreopened

OK, I tested for Ukrainian now:

Some messages are translated (mostly tooltips) but some are not:

As far as I can see, the only problem is upper case / lower case:

I copied the messages from the source but it seems Java randomly capitalizes some words:

"Files of type:" --> "Files of Type:"

(Or maybe Java has updated the messages slightly in later versions.)

What shall we do about it?

comment:10 Changed 11 years ago by bastiK

(In [3326]) see #5093 (translate more messages)

comment:11 Changed 11 years ago by bastiK

Ok added messages for other look and feels. Let's see if it helps ([o21627])

comment:12 Changed 11 years ago by bastiK

([o21628])

comment:13 Changed 11 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

(In [3340]) fixed #5093 - translation for open file

comment:14 Changed 11 years ago by bastiK

As said above, there seem to be slight variations in capitalization and punctuation. If you encounter another untranslated string in this dialog you can reopen and add the exact string. (Depends also on Look&Feel.)

I added already the 2 tooltips for ok and cancel in metal Look&Feel.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.