Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4976 closed defect (fixed)

filter : membership not shown in tag-list

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: filter membership hide Cc:

Description

If I filter on only nodes for example, all the relations are filtered, but if I select on of the nodes which is child of a relation, I do not get this information in the tag-list until I deselect the filter.

Please always show the memberships in the tag-list.

r3213

Attachments (1)

filter_example.osm (1.0 KB) - added by skyper 9 years ago.
example

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by bastiK

Could you please explain in more detail, I cannot reproduce this.

comment:2 Changed 9 years ago by skyper

Keywords: hide added

Ok, it happens only if you hide the other objects. The membership is aswell hidden in the property-list.

I upload an example.osm

Just filter for "addr:housenumber" revert this filter and select one node. Then hide everything else by checking the box in the filter-list. The node property-list does not show the membership of the associatedStreet-relation anymore.

I found another bug: filter does not interprete "-" -> I open another ticket #4988

Cheers skyper

Changed 9 years ago by skyper

Attachment: filter_example.osm added

example

comment:3 Changed 9 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3219]) Fix #4976 filter : membership not shown in tag-list

comment:4 Changed 9 years ago by jttt

Membership in filtered relations wasn't shown on purpose, but I agree it's better to have it shown. Filter relations are now shown after non filtered relations and with italic font

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.