Modify

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4975 closed defect (duplicate)

Network Exception when uploading through a proxy

Reported by: psolyca Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Hello,

I can download data with JOSM from OSM Server but I can not upload.
I am through an android phone connection and a proxy (ADB).
I can upload my GPX files with the web interface on openstreetmap.org, navigate on the internet.

I'm under WinXP but it is the same with Ubuntu.
My command :

java -DproxySet=true -Dhttp.proxyHost=127.0.0.1 -Dhttp.proxyPort=8080 -jar josm-tested.jar

I set the proxy on the windows preferences in JOSM to 127.0.0.1 and port 8080.

Here is the output in the DOS command prompt :

GET http://api.openstreetmap.org/api/capabilities... OK
Communication établie avec http://api.openstreetmap.org/api en utilisant le protocole de version 0.6
PUT http://api.openstreetmap.org/api/0.6/changeset/create... org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Unexpected end of file from server
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:608)
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:476)
        at org.openstreetmap.josm.io.OsmApi.openChangeset(OsmApi.java:316)
        at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:192)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:237)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.net.SocketException: Unexpected end of file from server
        at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
        at java.net.HttpURLConnection.getResponseCode(Unknown Source)
        at java.net.HttpURLConnection.getResponseMessage(Unknown Source)
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:532)

I searched on the internet but no solution found.
I change the server name but it is not working.
I try my mail or username to register but it is the same.

Thanks

Damien

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by psolyca

Hello,

I just try with a direct connection without proxy and upload works fine.

comment:2 Changed 9 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by stoecker

Closed as duplicate of #4216.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.