Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4963 closed enhancement (duplicate)

Validator to Fix abbreviated street names

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core validator Version: tested
Keywords: Abbreviated Name Cc:

Description

Can validator do an automatic fix o St to Street etc. in future? Or is there another way to do this currently?

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by Adam Dunn

The issue with automatically expanding abbreviations is that you don't know what it should be expanded to. Should St. become Street, or Saint, or South, or State, etc.

Do you have a proposition on how to overcome this?

comment:2 Changed 11 years ago by bastiK

Automatic fix is not such a good idea because there are always cases where the substitution is plain wrong. At maximum, validator plugin could detect these abbr. Then it can be corrected manually.

comment:3 Changed 11 years ago by stoecker

I already does detect abbreviations.

comment:4 in reply to:  2 Changed 11 years ago by todd.gabby@…

Replying to bastiK:

Automatic fix is not such a good idea because there are always cases where the substitution is plain wrong. At maximum, validator plugin could detect these abbr. Then it can be corrected manually.

Is there then a simple way once I have a selection of ways that I can confirm are all streets (But are tagged St) without having to select one, select the name tag, move to the "St" part, type "Street", close that one and move on to the next one? I suppose I am looking for a find/replace type operation.

comment:5 Changed 10 years ago by simon04

Resolution: duplicate
Status: newclosed

This multi-editing is covered in #5587.

comment:6 Changed 10 years ago by simon04

Closed as duplicate of #5587.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.