Modify

Opened 10 years ago

Closed 3 years ago

#4889 closed enhancement (duplicate)

Improve ticks for scale slider

Reported by: jstein Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by Don-vip)

there are 5 ticks at the scale

|--,--|--,--|
0       249m

why is the 3rd and the 5th tick larger?

The value "249m" is centered below the 4th tick. It should nominate the whole length.

Is it possible, to draw a individual bar with more human readable values?

Zoom A

|--,--|--,--|
0     50    100 m 

Zoom B

|---,---|---,---|
0       .5      1 km

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by stoecker

Resolution: fixed
Status: newclosed

(In [3234]) fixed #4889 - map scale middle line was too long

comment:2 Changed 9 years ago by anonymous

Resolution: fixed
Status: closedreopened

it looks if only the Line was fixed:
g.drawLine(49, 3, 49, 7);

the ticks should partition the distance in parts that make sense:

BAD:
1/4 of 249m = ?

NICE:
1/4 of 100m = 25 m

comment:3 Changed 9 years ago by stoecker

Resolution: wontfix
Status: reopenedclosed

Well, we have no real fine zoom steps, so there would be lots of work involved to have nice parts. Also it would confuse users when the scale changes verytime.

comment:4 Changed 9 years ago by jstein

Resolution: wontfix
Status: closedreopened
Summary: scale in josm editor area unclearticks make no sense Example: (29m /4 Ticks)
Type: enhancementdefect

it would only need to find the next matching scale.

at least each tick should represent an integer value of meter, else the ticks dont make any sense.

its confusion to divide 29 m in quarters, not to change the length of a bar.
There is nothing bad to change this bar to fit the scale of the map.

one could plot
length mod (4 * 10x) = 0 for values (0.. 32) * 10x
length mod (4 * 5 * 10x) = 0 for values (32..100) * 10x

where x is a factor to fit on all scales.

That should be easy to code and the ticks make sense then.

comment:5 in reply to:  4 ; Changed 9 years ago by bastiK

Replying to jstein:

That should be easy to code and the ticks make sense then.

Go ahead, then. :)

Currently we have too many requests for too view developers. Your suggestion makes sense, but maybe it'll take a while till someone does it.

comment:6 Changed 9 years ago by stoecker

Summary: ticks make no sense Example: (29m /4 Ticks)Improve ticks for scale slider
Type: defectenhancement

comment:7 in reply to:  5 Changed 3 years ago by Don-vip

Description: modified (diff)
Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #12644.
Replying to bastiK:

maybe it'll take a while till someone does it.

6 years :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.