Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12644 closed enhancement (fixed)

[Patch] Map view scale - Nicer painting

Reported by: michael2402 Owned by: team
Priority: normal Milestone: 16.04
Component: Core Version:
Keywords: zoom slider scale Cc: wiktorn, bastiK

Description (last modified by michael2402)

I changed the width/size of the map view scale, both the slider and the bar. I also changed the text to use round values.

Fixes #12593

Preview:

Attachments (2)

patch-map-view-scale.png (652 bytes) - added by michael2402 4 years ago.
patch-map-view-scale.patch (7.8 KB) - added by michael2402 4 years ago.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by michael2402

Attachment: patch-map-view-scale.png added

Changed 4 years ago by michael2402

Attachment: patch-map-view-scale.patch added

comment:1 Changed 4 years ago by michael2402

Description: modified (diff)
Summary: [Patch] Map view scale - Niver painting[Patch] Map view scale - Nicer painting

comment:2 Changed 4 years ago by Don-vip

Cc: wiktorn bastiK added
Component: Core mappaintCore
Keywords: zoom slider scale added

comment:3 Changed 4 years ago by Don-vip

@wiktorn: I see #12593 is closed as wontfix, are you ok with this change?

comment:4 Changed 4 years ago by michael2402

Feel free to change it back to 100:

int w = 100;

I mostly changed this because I thought that 100px is so small for the scale mark on modern screens.

comment:5 Changed 4 years ago by wiktorn

I'll take a look at this shortly after Eastern.

comment:6 Changed 4 years ago by wiktorn

Resolution: fixed
Status: newclosed

In 10078/josm:

New nicer map slider.

Patch submitted by: michael2402

Closes: #12644

comment:7 Changed 4 years ago by Klumbumbus

Milestone: 16.03

comment:8 Changed 4 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

comment:9 Changed 4 years ago by Don-vip

Ticket #4889 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.