Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4721 closed defect (duplicate)

exception raised trying to create a closed way

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. select the 'draw nodes' tool
  2. click on map (empty space or existing node, does not matter) to start drawing a way
  3. click a few more times to enclose an area
  4. doubleclick on first node to finish creating a closed way

What is the expected result?

should create a closed way

What happens instead?

exception is raised. final node in way is not added, though the earlier part of the way is created as expected.

Please provide any additional information below. Attach a screenshot if
possible.

tried this a few times, seems very reproducible in r3107. traceback is the same each time (at least the first few frames are, didn't compare exhaustively)

have not had this problem with previous versions (most recently used r3081)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-11 02:31:32
Last Changed Author: jttt
Revision: 3107
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-10 19:11:58 +0100 (Wed, 10 Mar 2010)
Last Changed Rev: 3107

Memory Usage: 162 MB / 1018 MB (45 MB allocated, but free)
Java version: 1.6.0_17, Apple Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Mac OS X

Dataset consistency test:
No problems found


Plugins: PicLayer,dataimport,graphview,lakewalker,measurement,remotecontrol,slippymap,validator,wmsplugin
Plugin wmsplugin Version: 19626
Plugin PicLayer Version: 19467
Plugin dataimport Version: 19681
Plugin remotecontrol Version: 19471
Plugin validator Version: 19688
Plugin slippymap Version: 19521
Plugin lakewalker Version: 19624
Plugin graphview Version: 19441
Plugin measurement Version: 19681

java.lang.UnsupportedOperationException
	at java.util.Collections$UnmodifiableCollection.clear(Collections.java:1037)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:510)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:273)
	at java.awt.Component.processMouseEvent(Component.java:6348)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3255)
	at java.awt.Component.processEvent(Component.java:6113)
	at java.awt.Container.processEvent(Container.java:2085)
	at java.awt.Component.dispatchEventImpl(Component.java:4714)
	at java.awt.Container.dispatchEventImpl(Container.java:2143)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4282)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
	at java.awt.Container.dispatchEventImpl(Container.java:2129)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by anonymous

Closed as duplicate of #4705.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.