Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4720 closed defect (duplicate)

Error when drawing a closed loop

Reported by: trekki <bergenholtz@…> Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. open a new josm session
  2. create a empty layer
  3. click a triangle of ways
  4. last of the 3 ways must connect to the start of the first way

What is the expected result?
a closed way in a triangle form

What happens instead?
crash

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-11 02:31:32
Last Changed Author: jttt
Revision: 3107
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-10 19:11:58 +0100 (Wed, 10 Mar 2010)
Last Changed Rev: 3107

Memory Usage: 70 MB / 2730 MB (45 MB allocated, but free)
Java version: 1.6.0_0, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux

Dataset consistency test:
No problems found


Plugins: wmsplugin,validator
Plugin wmsplugin Version: 19240
Plugin validator Version: 19229

java.lang.UnsupportedOperationException
	at java.util.Collections$UnmodifiableCollection.clear(Collections.java:1053)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:510)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.Component.processMouseEvent(Component.java:6108)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:5873)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Component.dispatchEventImpl(Component.java:4469)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Component.dispatchEvent(Component.java:4295)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
	at java.awt.Container.dispatchEventImpl(Container.java:2149)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4295)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (1)

Bildschirmfoto.png (143.9 KB) - added by trekki <bergenholtz@…> 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by trekki <bergenholtz@…>

Attachment: Bildschirmfoto.png added

comment:1 Changed 10 years ago by urbanrambler1

I'm experiencing exactly the same. I've just uploaded latest (3107) and editing JOSM for first time.

comment:2 Changed 10 years ago by bastiK

Resolution: duplicate
Status: newclosed

Why don't you use tested version then, for latest it says "may have more errors than "tested", be careful with this one".

comment:3 Changed 10 years ago by anonymous

Closed as duplicate of #4705.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.