Modify

Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#4664 closed defect (fixed)

warn when reverting a way with direction defined by tag

Reported by: skyper Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: revert way Cc: skyper

Description (last modified by skyper)

JOSM should warn when reverting a way with dirention defined by tag.

I know there are not many, but at least barrier=retaining_wall has a direction defined by this tag and the user is distroying data if he/she is reverting this way.
This can also happen by JOSM itself, when combining ways.

r3074 with sun, r3067 with openjdk

Attachments (0)

Change History (9)

comment:1 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by stoecker

Closed as duplicate of #4080.

comment:3 in reply to:  2 Changed 10 years ago by skyper

Priority: criticalmajor
Resolution: duplicate
Status: closedreopened

Replying to stoecker:

Closed as duplicate of #4080.

This is no duplicate, since we need to warn or even prohibit to revert these ways. There is no dialog needed.

comment:4 Changed 10 years ago by skyper

waterway=* should also not be reverted. I think a warning would be great. To prohibit it is off the line cause sometimes you want to revert objects. This check needs to be run also if 2 ways with different directions are connected to find the valid direction.

comment:5 Changed 8 years ago by skyper

Description: modified (diff)

natural=cliff is another tag with defined orientation.

comment:6 Changed 7 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 5724/josm:

fix #4664 - warn when reverting a way with direction defined by tag

comment:7 Changed 7 years ago by skyper

Resolution: fixed
Status: closedreopened

Found two more:

  • barrier=kerb
  • barrier=guard_rail

comment:8 Changed 7 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 5732/josm:

fix #4664 - Add new tags for directional tags

comment:9 Changed 7 years ago by Don-vip

Ticket #3274 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.