Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4080 closed defect (fixed)

check for tagvalue containing left/right or up/down when changing direction of a way

Reported by: skyper Owned by: stoecker
Priority: normal Milestone:
Component: Core Version: latest
Keywords: left right revert up down Cc: skyper

Description

Please have josm check for left/right in tags and tag-values when changing the direction of a way and offer to change it like it is done with oneway=*

Attachments (0)

Change History (28)

comment:1 Changed 11 years ago by stoecker

Owner: changed from team to skyper
Status: newneedinfo

This is already implemented. What specifically do you request.

comment:2 in reply to:  1 Changed 11 years ago by skyper

Replying to stoecker:

This is already implemented. What specifically do you request.

Then it does not work:
id: 23024460
footway=right
can change direction silently.
should offer to change to footway=left

also please check for cycleway:right=* and so on

comment:3 Changed 11 years ago by skyper

Owner: changed from skyper to stoecker
Status: needinfonew
Type: enhancementdefect

comment:4 Changed 11 years ago by mjulius

Type: defectenhancement

left/right in keys on ways is checked for and should work. left/right in values is not checked for.

comment:5 Changed 11 years ago by stoecker

If I remember correctly, the last time this was requested there existed not one established tagging standard, where left/right in values was used. Is there now something standardized?

comment:6 Changed 11 years ago by skyper

No, you are right.
But there are quite a lot of proposals about that and I see even more possibilities like (embankment and cutting).
Any way, that there is nothing yet establish does not mean that no one is using it.

comment:7 Changed 11 years ago by skyper

Anyway I think this would be a nice feature to save information and one big plus for JOSM.

comment:8 Changed 11 years ago by stoecker

When I say established standard, then I mean either:

  • used in real datasets (e.g. provide tagwatch hits)
  • documented in MapFeatures

Last time neither of these two existed.

I don't like to support anything when there are no use cases at all.

comment:9 Changed 11 years ago by mjulius

Well, according to osmdoc there are 709 ways tagged footway=right and 467 ways tagged footway=left. And, there is a proposal for footway=both|left|right|none.

comment:10 in reply to:  9 Changed 10 years ago by skyper

Keywords: left right revert added
Priority: normalmajor
Type: enhancementdefect

Replying to mjulius:

Well, according to osmdoc there are 709 ways tagged footway=right and 467 ways tagged footway=left. And, there is a proposal for footway=both|left|right|none.

There is even more right now: (2010-02-23 05:45 tagwatch europe) always left/right

alley			28/27
barrier:bannister	2/4
barrier:fence		2/3
barrier:geländer	3/-
barrier:guardrail	-/2
barrier:handrail	2/-
barrier:hedge		4/8
barrier:leitplanke	10/7
barrier:wall		5/-
bicycle			lane_left (5)
bicycle:footway  	4/-
bus			2/-
bus_stop:side		1/1
cutting			6/10
cycleway		137/228	lane_left/right 37/239	track_left/right 48/46	right_lane 9
direction_hint  	1/11
embankment		20/19
exit  			12/34
foot			21/9
footway 		1219/1661
handrail		5/2
landing_point		1/-
lane:ends		1/1
natural:tree		9/19
natural:trees		3/1
parking			6/11
parking_lane		15/7
parking_lanes		1/2
passing_place		5/4
path			11/16
platform		2/2
save_way		left/right_side 1/2
segregated		4/3
side			85/113
sidewalk		15/27
towpath			15/12
track			25/34
tracks			2/-
turnout			5/-

Maybe not all these tags apply to ways but a lot do.

I am turning this into a defect, because all this information is wrong if a way is reverted.

comment:11 Changed 10 years ago by skyper

Cc: skyper added

comment:12 Changed 10 years ago by skyper

Summary: check for left/right when changing direction of a waycheck for tagvalue containing left/right when changing direction of a way

comment:13 Changed 10 years ago by skyper

Please,
this works well with direction info in tags and roles, but not with any tag-values.
like footway/cyclewayembankment..=left/right, direction=up/down

comment:14 Changed 10 years ago by skyper

Priority: majorcritical

comment:15 Changed 10 years ago by skyper

Summary: check for tagvalue containing left/right when changing direction of a waycheck for tagvalue containing left/right or up/down when changing direction of a way

There exist also a tag incline=up/down which I personal do not like but it was accepted.

comment:16 Changed 10 years ago by skyper

Keywords: up down added

comment:17 Changed 10 years ago by stoecker

Priority: criticalnormal

comment:18 Changed 10 years ago by stoecker

Ticket #4664 has been marked as a duplicate of this ticket.

comment:19 Changed 10 years ago by skyper

At least incline=up/down was accepted quite some time ago.

Please add this feature. It is almost coded, you only need to check also for values, not only for the tags.

comment:20 Changed 10 years ago by skyper

Priority: normalmajor

comment:21 Changed 10 years ago by skyper

Priority: majorcritical

also direction=up/down was accepted.

comment:22 Changed 10 years ago by skyper

Ticket #4251 has been marked as a duplicate of this ticket.

comment:23 Changed 10 years ago by stoecker

Priority: criticalnormal

Please do not change priorities which have been change by admins. This is not critical. The above numbers show that these tags are actually not used widely.

comment:24 in reply to:  23 ; Changed 10 years ago by skyper

Replying to stoecker:

Please do not change priorities which have been change by admins. This is not critical. The above numbers show that these tags are actually not used widely.

There is no editor which supports these values and one arguement against footway=* was that there is no editor supporting it. That is why not many users are using them.

Who is admin ? - I might know it but not erveryone knows.

At least direction=up/down and incline=up/down are on the wiki.

comment:25 in reply to:  24 Changed 10 years ago by bastiK

Who is admin ? - I might know it but not erveryone knows.

Yes, but that's enough because you are the only one bumping tickets by raising the priority. I can imagine it must be frustrating if nothing happens for a long period of time, but there is not much you can do about it. Our developer resources are very limited and there are hundreds of things that need to be improved. This is only one of them and it is by no means a critical bug.

As you pointed out it is a relatively easy programming task, so if you like you can try yourself. Good user feedback is valuable and always welcome, but don't expect us to concentrate on your problems with the software only.

comment:26 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

(In [3190]) fixes #4080

comment:27 Changed 10 years ago by skyper

Thanks a lot

I fully accept your arguments.
The problem I often focus that I do not know if I am the only one with that problem or if it effects more. Seems to me that users do not give a comment if a bug is already reported.

I am working offline 80 % of the time. While being offline it is quite hard to contribute to josm.
Last month it was even hard for me to contribute to osm, cause of some nasty bugs in JOSM. I had to manage hundreds of conflicts.
Now it is working quite well and I might have some time to start coding or at least help with documentation.

Cheers

comment:28 Changed 10 years ago by bastiK

Would be great, I'm looking forward to it!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.