Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4597 closed defect (fixed)

search does not find id:0

Reported by: CharlesNepote Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: search id 0 Cc: charles@…, skyper

Description

Finding all modifications during a month for a given zone is very interesting.
Search for "timestamp:2010-02" was working fine but no longer works in version 3033.

Attachments (0)

Change History (10)

comment:1 Changed 10 years ago by jttt

You can try timestamp:"2010-02" (not tested)

comment:2 in reply to:  1 Changed 10 years ago by CharlesNepote

Replying to jttt:

You can try timestamp:"2010-02" (not tested)

Yes it works!
But you have to know it...

Either it must be documented.
Either "timestamp:2010-02" should be accepted.

I prefer the second solution.

comment:3 Changed 10 years ago by mjulius

Ticket #4621 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by skyper

Priority: normalmajor
Summary: Search for timestamp:2010-02 no longer worksSearch broken and search documentation outdated

I can not find id:0.

nor can I find "FIXME": through search.
I tried all possibilities, but I get no result.

comment:5 Changed 10 years ago by skyper

Cc: skyper added

version 3040

comment:6 Changed 10 years ago by bastiK

works for me (3044): Type FIXME or FIXME=*

Bug: The latter is case sensitive although the option is unticked.

(I can confirm id:0 is broken.)

Replying to Ldp (Ticket #4621):

Fine, but what does the number mean to the search compiler, in this specific case? Is this parsing just a byproduct of the generic parsing for the other search options that have numberic modifiers, like nodes: and timestamp: ?

I think it's a defect and should be fixed.

comment:7 Changed 10 years ago by mjulius

Resolution: fixed
Status: newclosed

(In [3046]) fixes #4597 - Search for timestamp:2010-02 no longer works

Searching for strings starting with digits should not require quotes anymore.

comment:8 Changed 10 years ago by skyper

Keywords: id 0 added
Priority: majorminor
Resolution: fixed
Status: closedreopened
Summary: Search broken and search documentation outdatedsearch does not find id:0

Search does not find id:0. I do not know if it was fixed, yet, or if we forgot about my note.

I do find version:0 so, which works as workaround.

r3131, r3135

comment:9 Changed 10 years ago by jttt

Resolution: fixed
Status: reopenedclosed

(In [3140]) Fix #4597: search does not find id:0

comment:10 Changed 10 years ago by skyper

Ticket #4741 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.