Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4621 closed defect (duplicate)

Search key values beginning with number doesn't work

Reported by: Ldp Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Create an object, tag it with foo=2bar. Searching for foo=2bar doesn't find any objects. Searching for foo="2bar" works. Why are the quotes a requirement? Am I missing a special search mode where a key value beginning with a number means something special to the search engine?

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by mjulius

Resolution: duplicate
Status: newclosed

This is the way JOSM currently works. If a string starts with a digit the search compiler tries to read a number.

comment:2 Changed 11 years ago by mjulius

Closed as duplicate of #4597.

comment:3 Changed 11 years ago by Ldp

Fine, but what does the number mean to the search compiler, in this specific case? Is this parsing just a byproduct of the generic parsing for the other search options that have numberic modifiers, like nodes: and timestamp: ?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.