Modify

Opened 11 years ago

Closed 11 years ago

#4376 closed defect (fixed)

Update plugins doesn't remember skipping

Reported by: Daeron Owned by: stoecker
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I update my josm and plugins manually from svn. I tried to select the remember checkbox, and then skip update, but the dialog still appear every time i have updated my josm.

Attachments (0)

Change History (12)

comment:1 Changed 11 years ago by stoecker

Owner: changed from team to Gubaer

HelpAwareOptionPane does not care for the dontShowAgain message at all, so it is no wonder it does not work.

@Gubaer:
You need to copy the dont show functionality from ExtendedDialog to HelpAwareOptionPane instead of having a special UpdatePluginPanel which anway does not work, as it does not affect behaviour of the dialog.

BTW: using pluginmanager.version instead of message.pluginmanger.version also kills the version check.

comment:2 Changed 11 years ago by Gubaer

Owner: changed from Gubaer to stoecker

If you already know *how* to fix it, then please fix it instead of providing a lenghty analysis. You have commit rights. Don't explain how to fix things, if nobody asks for it, just fix them.

comment:3 Changed 11 years ago by stoecker

Between finding the reason and the actual fix usually is a longer time. I investigated the reason, found it to be a non-trivial cause and assigned it to the one who produced the bug.

comment:4 Changed 11 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2866]) fixed #4376: Update plugins doesn't remember skipping

comment:5 Changed 11 years ago by stoecker

Resolution: fixed
Status: closedreopened

This fix removes the previously existing possibility to select what you really want: update or cancel. Adding new functionality is nice, but removimng stuff which has been requested in many Trac tickets is not really the way to go.

comment:6 Changed 11 years ago by stoecker

I still do not understand why ExtendedDialog needs to be replaced by HelpAwareOptionPane at all.

comment:7 Changed 11 years ago by Gubaer

I still do not understand why ExtendedDialog needs to be replaced by HelpAwareOptionPane at

all.

Let me explain.

Remember the former situation: when the ExtendedDialog was launched, the splash screen was hidden (by some automagic trigger in the SplasScreen class I've removed too). There is no need to hide it and I didn't want to hide it anymore because it now displays progress information during startup (which wasn't the case before). Next step was to lauch the ExtendedDialog with the splash screen as parent which didn't work either, first because on Linux it was displayed behind the splash screen, and second because it was launched with the wrong size (collapsed to mininum size). I could have tried to fix the size issue in ExtendedDialog, instead I opted to replace it with HelpAwareOptonPane. It works and the user experience is at least as good as with ExtendedDialog (did you notice the tooltip texts on the buttons, which you didn't have before?). In the meantime the splash screen turned into an undecorated JFrame which would probably allow to use ExtendedDialog again, but there's no need switch back. HelpAwareOptionPane works just fine.

comment:8 Changed 11 years ago by stoecker

Well, there are several issues here, which are hidden:

  • Don't show again now working as expected
  • Splash screen will hide any messages (the plugin message is not the only one).

The "splash screen disappears" was a solution, which fixed a larger sets of startup troubles caused by hidden dialogs which could not be modified, seen or handled. When you disabled that feature, than we have all these troubles back. Go back to the time when splash was introduced and check Trac there. Many issues have been related to this until the disappear was added.

I don't think removing this feature is really a good idea.

comment:9 Changed 11 years ago by Gubaer

The "splash screen disappears" was a solution, which fixed a larger sets of startup
troubles caused by hidden dialogs which could not be modified, seen or handled.
When you disabled that feature, than we have all these troubles back.

Why? Which troubles are back? Why do you think the splash screen will hide any message? Pardon me, but this sound like FUD to me.

As I explained above, hiding the splash screen was suboptimal. I tried to find a better solution and apparently I did, see #4365. It's tested on Linux and Windows, user report it to work and it's closed.

If you want to continue this, please reopen #4365 and continue there. This tickets deals with another issue. Let's just fix it and close it.

comment:10 Changed 11 years ago by stoecker

Why do you think the splash screen will hide any message?

You said yourself, that "I could have tried to fix the size issue in ExtendedDialog, instead I". This means ExtendedDialog as well as probably all other dialogs still are hidden behind splash screen. This includes all error dialogs as well as any other messages we have.

comment:11 Changed 11 years ago by Gubaer

This means ExtendedDialog as well as probably all other dialogs still are hidden behind splash screen.

"Probably" is not good enough. The result of recent tests of myself and other users indicate: no they aren't. Again, if something is broken there please reopen #4365. Here it's off topic.

comment:12 Changed 11 years ago by Gubaer

Resolution: fixed
Status: reopenedclosed

Fixed in r2924.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.