Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4006 closed defect (duplicate)

Delete is broken

Reported by: Daeron Owned by: Daeron
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When deleting ways (or possibly combining two ways), they are not always removed from relations thus breaking uploading.

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by Gubaer

Can you post the error message you get on uploading? Is it a 412 Precondition Violation?

Perhaps the ways are part of relations which are not loaded into the local dataset. JOSM tells you what relation is involved in the Precondition Violation. Can you check (search for the id in your local dataset) whether it locally available?

If it isn't, this isn't a defect.

comment:2 Changed 10 years ago by jttt

Maybe this is related to #4006. If referrers get broken than QuadBuckets for ways is no longer updated (#4006) and deleting can miss some referrers (#4001).

comment:3 in reply to:  1 Changed 10 years ago by Daeron

Replying to Gubaer:

Can you post the error message you get on uploading? Is it a 412 Precondition Violation?

Perhaps the ways are part of relations which are not loaded into the local dataset. JOSM tells you what relation is involved in the Precondition Violation. Can you check (search for the id in your local dataset) whether it locally available?

If it isn't, this isn't a defect.

Yes, I got a 412, and yes, the relation was in the local dataset (downloaded at the same time as the way). The relation editor showed the way as having zero nodes, ie. deleted. I manually deleted the way from the relation and then the upload completed successfully.

comment:4 Changed 10 years ago by stoecker

Owner: changed from team to Daeron
Status: newneedinfo

Zero nodes does not mean deleted. The node count has nothing to do with the deletion state. Could you make this situation reproducable?

comment:5 Changed 10 years ago by Daeron

Resolution: duplicate
Status: needinfoclosed

Okay, found a way to reproduce.

When you have a two-node way as a member of a relation, and the way is deleted by deleting the only segment (shift delete), it's not removed from the relations, thus leading to precondition violation when uploading (It tries to delete the way, but it's still a member of relation(s)).

So, this is pretty much the same as #3704, although leading to more severe problems.

comment:6 Changed 10 years ago by Daeron

Closed as duplicate of #3704.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Daeron.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.