Modify

Opened 10 years ago

Closed 10 years ago

#3704 closed defect (fixed)

Relation memberships are not handled at all when a way is splitted or deleted by deleting a segment

Reported by: Daeron Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When a segment is deleted from a way, and it is not in either end, the way is splitted. The created way doesn't have any memberships the original way had, thus breaking relations.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by Daeron

Ticket #4006 has been marked as a duplicate of this ticket.

comment:2 Changed 10 years ago by Daeron

Summary: Relation memberships are not handled at all when a middlesegment is deleted from a wayRelation memberships are not handled at all when a way is splitted or deleted by deleting a segment

Also, when deleting a way completely by deleting a segment (two-node way), it won't be deleted from the relations it's a member of, thus leading to 412 Precondition Violation when uploading.

comment:3 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

Fixed in r2521

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.