Modify

Opened 10 years ago

Closed 10 years ago

#3703 closed defect (worksforme)

Relation memberships not handled correctly for ways segment deleting

Reported by: Daeron Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

This patch makes the deleteWaySegment to just modify circular ways when a segment is deleted and not split the way at the first/last node, which is in practice always not what the user wanted.

Attachments (1)

delete_segment.patch (1.8 KB) - added by Daeron 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Daeron

Attachment: delete_segment.patch added

comment:1 Changed 10 years ago by stoecker

(In [2296]) see #3703 - patch by Daeron - deleting way segment cleanup

comment:2 Changed 10 years ago by stoecker

Summary: [PATCH] Don't split a circular way when a segment is deletedRelation memberships not handled correctly for ways segment deleting

comment:3 Changed 10 years ago by Gubaer

Resolution: worksforme
Status: newclosed

Run a couple of tests.

  • Delete the middle segment from a way with three segments which belongs to a relation. Expected: the relation should still have the same member with the same role refering to the same way. In addition it should have a new member in adjacent position to the original member pointing to a new way (which is created because the way is split) and having the same role as the original members. Result: Looks fine.
  • Delete the unique segment from a way with exactly one segment which belongs to a relation. Expected: this should delete the way and the member should be removed from the relation.
    JOSM displays a confirmation dialog to remove the way from the relation, as expected. If confirmed, the way is deleted and removed from the relation. Result: Looks fine.

Closing as worksforme.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.