Modify

Opened 10 years ago

Closed 9 years ago

#3772 closed defect (fixed)

Help browser calling external program

Reported by: stoecker Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

Currently the help browser is calling an external program (java) to establish independency for modal dialogs. This is nothing which should be inside josm's core.

This call will be removed until tested, hopefully replaced by a better solution. If not the old blocking method will be reintroduced.

Idea how to solve: Set help dialog modal and modal dialog non-modal when help from modal dialog is called.

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by Gubaer

Works fine on Windows Vista and Ubuntu.

Any other environments where it doesn't work?

comment:2 Changed 9 years ago by stoecker

Ticket #3901 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by stoecker

Ticket #4087 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by stoecker

Resolution: fixed
Status: newclosed

(In [2715]) fixed #3772, #4139 - fixed help browser - the external start never worked for official releases, the blocking of helpbrowser for dialogs will be fixed after Java 1.6 switch

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.