Modify

Opened 9 years ago

Closed 5 years ago

#3764 closed enhancement (fixed)

make error messages copy-able

Reported by: malenki Owned by: team
Priority: minor Milestone: 14.03
Component: Core Version: latest
Keywords: copy error message Cc:

Description

This will be helpful since on one hand one hasn't to attach a screenshot for just a message and on the other hand one is able to copy node and way ids without having to copy it by hand

Attachments (5)

3764.patch (19.1 KB) - added by simon04 5 years ago.
bugreport_bug.png (40.6 KB) - added by Don-vip 5 years ago.
otherbug.png (16.1 KB) - added by Don-vip 5 years ago.
bug-ugly-background.png (6.7 KB) - added by aceman 5 years ago.
OK, so I determined the ugly background is only seen in the Nimbus theme shipped with JOSM. Other 3 themes seem OK.
corrupt_auto_corect.png (10.0 KB) - added by skyper 5 years ago.
screenshot of buggy message

Download all attachments as: .zip

Change History (23)

comment:1 Changed 5 years ago by Don-vip

Ticket #5549 has been marked as a duplicate of this ticket.

Changed 5 years ago by simon04

Attachment: 3764.patch added

comment:2 Changed 5 years ago by simon04

Milestone: 14.02
Summary: make error messages copy-able[Patch] make error messages copy-able

Attached patch that bases JMultilineLabel on JEditorPane in order to achieve select/copy-ability.

comment:3 Changed 5 years ago by Don-vip

should we apply this patch? :)

comment:4 Changed 5 years ago by stoecker

Any negative effects? If not - yes. I hate it when Copy&Paste does not work.

comment:5 Changed 5 years ago by Don-vip

Milestone: 14.0214.03

I don't know, we'll see for next release.

comment:6 Changed 5 years ago by Don-vip

In 6901/josm:

see #3764 - make UI messages copy-able (patch by simon04)

Changed 5 years ago by Don-vip

Attachment: bugreport_bug.png added

comment:7 Changed 5 years ago by Don-vip

Small problem:



Last edited 5 years ago by Don-vip (previous) (diff)

Changed 5 years ago by Don-vip

Attachment: otherbug.png added

comment:8 Changed 5 years ago by Don-vip

this bold stuff leads to another UI problems in dialogs:


comment:9 Changed 5 years ago by Don-vip

In 6911/josm:

see #3764 - disables "all bold" stuff by default. UI problems remain to fix

comment:10 Changed 5 years ago by Don-vip

In 6925/josm:

see #3764 - fix layout of bug report window

comment:11 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6932/josm:

fix #3764 - add stylesheet for html ordered and unordered lists, for use in error messages

comment:12 in reply to:  4 Changed 5 years ago by aceman

Replying to stoecker:

Any negative effects? If not - yes. I hate it when Copy&Paste does not work.

The frame containing the text in a dialog have now different background then the rest of the dialog. So it looks ugly. But maybe it is some strange interaction of the themes (JOSM theme and desktop environment theme). But it didn't happen before this patch. I'll attach a screenshot from linux when I get to it.

Changed 5 years ago by aceman

Attachment: bug-ugly-background.png added

OK, so I determined the ugly background is only seen in the Nimbus theme shipped with JOSM. Other 3 themes seem OK.

comment:13 Changed 5 years ago by aceman

The ugliness being the white background behind the copyable text while the rest of the dialog/popup is blueish. In all other themes everything is uniform blueish/metal as it should.

comment:14 Changed 5 years ago by Don-vip

In 6935/josm:

see #3764 - special handling for Nimbus

Changed 5 years ago by skyper

Attachment: corrupt_auto_corect.png added

screenshot of buggy message

comment:15 Changed 5 years ago by skyper

Resolution: fixed
Status: closedreopened
Summary: [Patch] make error messages copy-ablemake error messages copy-able

I am not sure but it seems that this change did corrupt other warnings. I had a strange validator upload message two days ago and today I have a totally corrupt warning message about reverting a way with 'oneway=yes':

screenshot of buggy  message

EDT: If I select two ways, the second warning is normal only the first is unusable.

Last edited 5 years ago by skyper (previous) (diff)

comment:16 Changed 5 years ago by Don-vip

Can you check if it affects all look and feels on your machine? The display of this warning is fine on Windows.

comment:17 Changed 5 years ago by aceman

Works great on Nimbus now, thanks!

comment:18 Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 6944/josm:

fix #3764 - should fix UI problem in tag correction dialog (cannot reproduce)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.